
 

 

VIP Task Manager Pro 

HelpAndM anual_unregistered_ev aluation_copy 



 

2 Contents 

2 

VIP Task Manager Pro 

 

Table of Contents 

Part I Introduction 5 

................................................................................................................................... 5 1 What is VIP Task Manager 

Part II User Start Up 6 

................................................................................................................................... 6 1 Step 1. Setting 

.......................................................................................................................................................... 6 Setting Task Groups  
.......................................................................................................................................................... 10 Setting Roles  
.......................................................................................................................................................... 13 Setting Resources  
.......................................................................................................................................................... 15 Setting Workflow  
.......................................................................................................................................................... 18 Setting Tasks  

................................................................................................................................... 21 2 Step 2. Planning 

.......................................................................................................................................................... 21 Planning Tasks  

.......................................................................................................................................................... 25 Planning Resources  

.......................................................................................................................................................... 26 Planning Time  
................................................................................................................................... 29 3 Step 3. Communication 

.......................................................................................................................................................... 29 Sending & Receiving Notifications  
................................................................................................................................... 31 4 Step 4. Management 

.......................................................................................................................................................... 31 To Do List Management  

.......................................................................................................................................................... 32 Project Management  

.......................................................................................................................................................... 33 Schedule Management  
................................................................................................................................... 35 5 Step 5. Tracking & Reporting 

.......................................................................................................................................................... 35 Applying Filters  

.......................................................................................................................................................... 36 Watch List  

.......................................................................................................................................................... 37 History  

.......................................................................................................................................................... 38 Customizing Views  

.......................................................................................................................................................... 40 Exporting  

.......................................................................................................................................................... 41 Printing  

Part III User Interface 42 

................................................................................................................................... 42 1 Interface Summary 

................................................................................................................................... 43 2 Main Menu 

................................................................................................................................... 45 3 Task List View 

................................................................................................................................... 54 4 Task Tree View 

................................................................................................................................... 60 5 Calendar View 

................................................................................................................................... 65 6 Resource List View 

................................................................................................................................... 72 7 Task Groups Panel 

................................................................................................................................... 78 8 Filters Panel 

................................................................................................................................... 84 9 Notifications Panel 

................................................................................................................................... 90 10 Notes Panel 

................................................................................................................................... 96 11 Comments Panel 

................................................................................................................................... 103 12 Resource Assignment Panel 

................................................................................................................................... 110 13 Attachments Panel 

................................................................................................................................... 116 14 Task History Panel 



 

3 Contents 

3 

VIP Task Manager Pro 

 

................................................................................................................................... 121 15 Permissions Panel 

................................................................................................................................... 127 16 Date Navigator Panel 

................................................................................................................................... 129 17 Roles Panel 

................................................................................................................................... 134 18 Charts panel 

Part IV User Manual 142 

................................................................................................................................... 142 1 Tasks 

.......................................................................................................................................................... 142 How to create a new task  

.......................................................................................................................................................... 143 How to edit a task  

.......................................................................................................................................................... 144 How to delete a task  

.......................................................................................................................................................... 145 How to set/change task priority  

.......................................................................................................................................................... 147 How to set/change task group  

.......................................................................................................................................................... 149 How to set/change task Estimated or Actual Time  

.......................................................................................................................................................... 150 How to set/change task status  

.......................................................................................................................................................... 152 How to set/change task Due Date  

.......................................................................................................................................................... 154 How to set/change task Completion  

.......................................................................................................................................................... 155 How to set/change task Start and Finish Date  

.......................................................................................................................................................... 156 How to set task recurrence  

.......................................................................................................................................................... 158 How to set task reminder  

.......................................................................................................................................................... 160 How to assign the task to particular resource(s)  

.......................................................................................................................................................... 161 How to attach files or links to the task  

.......................................................................................................................................................... 163 How to add notes to the task  

.......................................................................................................................................................... 165 How to add comments to the task  

.......................................................................................................................................................... 167 How to group tasks  

.......................................................................................................................................................... 169 How to track task history  

.......................................................................................................................................................... 170 How to sort tasks  

.......................................................................................................................................................... 172 How to filter tasks  

.......................................................................................................................................................... 182 How to export tasks  

.......................................................................................................................................................... 183 How to set task changes notifications  

.......................................................................................................................................................... 184 How to import tasks  

.......................................................................................................................................................... 185 How to print out tasks  

.......................................................................................................................................................... 198 How to create new task workflow  

.......................................................................................................................................................... 202 How to create a new task custom field  

.......................................................................................................................................................... 207 How to enter custom field values of the task  

.......................................................................................................................................................... 208 How to place the task to archive and return it back  

.......................................................................................................................................................... 210 How to duplicate the task   

.......................................................................................................................................................... 211 How to create links to the tasks from other applications  

.......................................................................................................................................................... 212 How to make graphic reports on the tasks  

.......................................................................................................................................................... 217 How to send the tasks by e-mail  

.......................................................................................................................................................... 230 How to send notifications of task changes by e-mail  

.......................................................................................................................................................... 231 How to import from MS Outlook  

.......................................................................................................................................................... 235 How to assign a task to its owner by default  

.......................................................................................................................................................... 236 How to make HTML or RTF reports of the tasks  
................................................................................................................................... 239 2 Task Groups 

.......................................................................................................................................................... 239 How to create new task group  

.......................................................................................................................................................... 241 How to edit task group  

.......................................................................................................................................................... 242 How to delete task group  

.......................................................................................................................................................... 244 How to add notes to task group  

.......................................................................................................................................................... 245 How to sort task groups  

.......................................................................................................................................................... 246 How to assign the resource to receive notifications of task group changes  

.......................................................................................................................................................... 247 How to set custom fields for the task group  

.......................................................................................................................................................... 251 How to enter custom field values of the task group  

.......................................................................................................................................................... 252 How to place the task group to archive and return it back  

.......................................................................................................................................................... 253 How to duplicate the task group  



 

4 Contents 

4 

VIP Task Manager Pro 

 

.......................................................................................................................................................... 255 How to insert the duplicate of task group  

.......................................................................................................................................................... 257 How to assign default resource(s) for the task group  

.......................................................................................................................................................... 258 How to make graphic reports on the task group  

.......................................................................................................................................................... 263 How to send task groups by e-mail  
................................................................................................................................... 268 3 Resources 

.......................................................................................................................................................... 268 How to create a new resource  

.......................................................................................................................................................... 269 How to edit a resource  

.......................................................................................................................................................... 270 How to delete a resource  

.......................................................................................................................................................... 271 How to create a new role  

.......................................................................................................................................................... 272 How to edit a role  

.......................................................................................................................................................... 273 How to delete a role  

.......................................................................................................................................................... 274 How to assign resource(s) to role  

.......................................................................................................................................................... 275 How to assign permissions to role and resource  

.......................................................................................................................................................... 276 How to filter resource  

.......................................................................................................................................................... 277 How to set task notifications  

.......................................................................................................................................................... 278 How to assign supervised resource  

.......................................................................................................................................................... 279 How to sort resources  

.......................................................................................................................................................... 280 How to group resources  

.......................................................................................................................................................... 281 How to export Resource List  

.......................................................................................................................................................... 282 How to print out Resource List  



 

Introduction VIP Task Manager Pro 5 

 

1 Introduction 

1.1. What is VIP Task Manager 

VIP  Task  Manager  Professional  Edition  is  a  client/server  software  for  team  collaboration  based  on 
access permissions. Authorized users can simultaneously access the common database through Local Network 
(LAN) to see, add and edit certain tasks, if they are granted appropriate permissions. It is the best solution for 
planning,  scheduling,  sharing,  tracking  and  reporting  tasks,  appointments,  projects,  and  any  company 
activities  in  small  and  midsize  business,  government  and  non-government  institutes,  non-profit  and 
educational organizations. 

Thank you for choosing VIP Task Manager! 

We sincerely hope you enjoy our program. 
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2 User Start Up 

2.1. Step 1. Setting 

2.1.1. Setting Task Groups 

After  you  have  successfully  installed  VIP  Task  Manager,  you  can  start  organizing  your  company  activity, 
roles,  resources  and  workflow into  one  common database.  As  program Administrator,  you  can  change  these 
setting anytime and permit other users to change them if there is a team that manages your company workflow. 

Company activities should gather logically-related tasks into task groups. Your company may have process-, 
project-, product-, client-, etc. oriented activity, so you should decide which way is better for your company. 

Process-oriented   Project-oriented 

  Product-oriented   Client-oriented 

The parent Task Group is created by default and has a name of the database file. You can rename it if you 
want.  
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Select Task Group Click on New Group button  

Enter Name of Task Group and click OK   

If main Task Groups are not enough, you can create sub-groups the same way you created main ones:              
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Select a Task Group Click on New Group button 

Enter Name of Task Group and click OK   
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Another important  thing you should do is to create personal Task 
Group  for  each  team  member.  They  use  these  folders  to  manage 
minor  tasks  (ex.:  the  tasks  they  should  do  to  complete  the  tasks 
assigned to them by their manager). By default no one else except 
for that particular user will be able to see his or her Task Group and 
tasks in it.  Let's not do it  now as there is an option to create these 
Task  Groups  automatically  when  adding  new  users  (see  Setting 
Resources). 



 

User Start Up VIP Task Manager Pro 10 

 

2.1.2. Setting Roles 

A role allows you to  assign specific permissions to  a  user  group,  i.e.  permission to  view,  create,  edit  and 
delete Tasks and Task Groups. For example, 'Team Leader' Role can allow to view, create, edit and delete 
Tasks  and  Task  Groups,  while  'Team  Member'  Role  can  allow  only  to  view  and  edit  Tasks  and  Task 
Groups. If you don't want to restrict your users at all, there is a default Role 'Unlimited' that automatically 
grants all permissions for all tasks. 

Select  Resource List  tab 

Click on New Role button 

Enter Name of Role and click OK 

                                        

When you create a role, it is denied any permission by default. You should grant each Role its permissions 
to  manage  Task  Groups.  The  permissions  granted  for  a  Task  Group  are  automatically  inherited  by  its 
Sub-Groups and Tasks. For Example, if you allowed 'Team Member' Role to view and edit Tasks in 'Project' 
Task Group, it will be able to view and edit Tasks in Task Group 'Stage 1', 'Stage 2', etc.  
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Select Task Tree tab Highlight a Task Group 

Permissions panel is in the right bottom of the program window. Above the permission grid there is a line 
that tells you which Task Group or Task is highlighted and granted permissions now.  

Select a permission cell  Click on Allow button 

If don't want a Sub-Group or a Task to inherit permissions of its  Task Group but rather have permissions 
different from its parent Group, you can change its permissions individually. 

Highlight a Task Sub-Group       Select a cell and click on Deny button  

         

Alternatively, if you need a Sub-Group or a Task to inherit permissions from its parent Task Group, you can 
cancel its own permissions.  



 

User Start Up VIP Task Manager Pro 12 

 

 Highlight a Task Group or Task 

 Select a permission cell  

 Click on Inherited From Parent button 

Note:  You can grant the same permissions to several Roles at once if selected appropriate cells.   
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2.1.3. Setting Resources 

Your company resources may include any human resources available, ex.: employees, partners, contractors, 
etc. i.e. all concerned, however, we advise you to add only people (users) who will use the program in the 
LAN.  

 Select  Resource List  tab      Click on  New Resource  button 

General  tab  allows  you  to  enter  some  Resource 
information  such  as  name,  e-mail,  department,  job 
title,  address,  and  phone  number.  If  a  Resource  is  a 
user  of  the  program  you  should  grant  check  Login 
Permission set a password for Resource to log in. The 
Resource can  change this  password later  when he or 
she  starts  using  the  software.  If  a  resource  can  be 
assigned  to  a  Task  you  should  check  Assignment 
Permission.  If  a  Resource  is  allowed  to  create,  edit 
and  delete  other  Resources,  you  should  check 
Administration  Permission.  

 Enter Resource information 

 Check or uncheck checkboxes  

 Click OK 
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When  you  assign  a  Resource  to  a  particular  Role  or 
Roles  you  created,  this  Resource  is  granted 
permissions of this Role. For example, If you assign a 
Resource  to  'Team  Member'  Role  which  allows  only 
to see and edit the Tasks in Task Group 'Projects', this 
Resource will not be able to create and delete Tasks in 
Task Group 'Projects'. It saves your time as you don't 
have  to  set  permissions  for  each  Resource 
individually,  all  you  need  to  do  is  to  assign  the 
Resource  to  appropriate  Role  that  is  granted  certain 
permissions.  

 Select Roles tab  

 Check appropriate Roles 

 Click OK 

Notifications  tab  lets  you  choose  the  types  of 
Notification this particular Resource will receive if he 
or  she  is  associated  with  the  Task  somehow  (The 
Resource is either Owner or Assigned to the Task). By 
default  all  types  of  Notifications  are  checked  so  the 
Resource  will  receive  Notifications  each  time  any 
attribute  of  the  Task  is  changed.  In  practice  the 
Resource  will  need  to  receive  only  some  of  these 
Notifications,  for  example  when  the  Resource  is 
assigned to the Task or when the Status of the Task is 
changed,  so  it  is  better  to  check  only  those  types  of 
Notifications the Resource really needs to receive. The 
Resource  can  check  Notification  types  himself  when 
he starts using the software. 

 Select Notifications tab  

 Check appropriate Event Types 

 Click OK 

Note: You will be asked if you want to create a personal folder for each new user. Click 'Ok', if you want 
to. 
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2.1.4. Setting Workflow 

Task  Workflow is  the  number  and  sequence  of  Statuses  the  Task  should  go  through  from the  moment  of 
initiation to  complete  accomplishment.  For  example,  the  default  task  workflow starts  with   'Draft'  Status, 
when  task  is  outlined  but  not  scheduled,  assigned,  communicated,  etc.  Then  it  becomes  'Created'  i.e. 
scheduled,  assigned  to  Resource  and  Notification  of  it  is  sent  to  all  concerned.  When  the  Task  is  being 
handled  by  assigned  Resource,  it  has  'In  Progress'  Status.  Sometimes  it  may  be  'Cancelled'.  When  the 
Task is 'Completed' by assigned Resource, it can be 'Verified' by Owner or Supervisor.   

Select Custom Workflow in menu Tools 

Each company has its own workflow so you can create your own Task Statuses, as well as create multiple 
workflow for different types of Tasks. 

Click on New Workflow button  



 

User Start Up VIP Task Manager Pro 16 

 

Enter Name and Click OK Click on New Status button 

Give a name to the status and decide whether Task Status is 
connected with % of Task Completion. For example, if you 
create  'Half  Done'  Status,  checked   Complete  and  selected 
Strong Value 50, each time you change Status of a Task to 
'Half Done', the % in the Complete column of Task List and 
Task Tree view will be changed accordingly to 50%.  

You can  set  a  font  color  and  image (.bmp 16x16 px)  for  this 
status.  

If you import a database from VIP Team To Do List you can 
associate the Status with the one from VPXML Status list.  

You  can  turn  Notification  mode  'on'  and  'off'  for  each 
Status,  i.e.  when  a  Task  Status  changes  to  the  one  with 
Notification 'Off', the Notification is not sent.   

If you uncheck  Active , the Status will not be available for new 
Tasks.   

Assign ID number for this status using “Value” entry field and 
up-down buttons. 

You can set the order in which Statuses will go one after another as a recommended task workflow for your 
employees or team members. Also you can set order in which types of Workflow will appear in drop down 
list for selection. 
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 Select a Status or Workflow 

 Click on Move Up button    
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2.1.5. Setting Tasks 

Besides Name, all Tasks have the following default parameters:  

ID  – Unique number given to the Task when it is created 

Info – Shows if the Task has Notes, Reminder or Attachment  

Task Group  – Folder to which the Task belongs  

Priority – Shows the level of urgency or importance of the Task 

Status  – Shows the current state of the Task in given Workflow  

Complete – Shows how much of the Task is already done in percentage  

Attachment – Shows the first attached file or link of the Task  

Owner – User who created the Task 

Assigned – User who is assigned to the Task 

Department – Department to which Assigned user belongs to 
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Start Date – Shows the date when the Task should be started 

Finish Date – Shows the date when the Task should be completed 

Due Date – Shows the date by which the Task should be completed (deadline) 

Time Left – Shows the time left till the Due Date  

Estimated Time – Shows how much time the Task is supposed to take 

Actual Time – Shows how much time the Task really took 

Date Created – Shows the date when the Task was created 

Date Last Modified – Shows the latest date when the Task was modified  

Date Started  - Shows the date when the task is started 

Date Completed - Shows the date when the task was completed 

If  you  don't  need  any  of  these  parameters,  you  can  easily  remove  them  from  your  Task  List.  (see 
Customizing Views). If you need more parameters, you can easily add them to your Task list.   

  

Select Custom Fields in Tools menu  

               Click on New button   

Set parameters for Custom Field:  

Title – Name of this Custom Field 
Type – Possibility to select the type of this Custom Field 
Allow filtering – Possibility to filter Tasks by Custom Field 
Allow grouping – Possibility to group Tasks by Custom Field 
Required – This Custom Field is required when adding or editing Tasks 
Formula – Possibility to enter some mathematical, logical and statistical formula for this custom field  
Active – This Custom Field is activated  
Default value – The data used by default when creating Tasks 
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Note, that you can edit and delete Custom Fields as well as change their order. 
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2.2. Step 2. Planning 

2.2.1. Planning Tasks 

All  users  granted  Permission  to  create,  edit  and  delete  Tasks  and  Task  Groups  can  take  part  in  planning 
company activity using Task List, Task Tree and Calendar view. If your company workflow supposes that 
only managers may plan work for the staff, the staff should be denied the permission to create Tasks in Task 
Groups.  

When  you  name  a  task,  be  specific  but  don’t  go 
into details you can describe in Notes (see below). 
You can change “Normal” priority, set by default, 
to  the  more  suitable  one:  Lowest,  Low,  High, 
Highest or Urgent. 

Enter Name of the Task 

Select Priority of the Task 
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You should assign the task to a certain Task Group or sub-Group. When planning a task we recommend you 
to  set  Status  'Draft'  which  Notification  mode  is  disabled  so  you  can  edit  it  without  sending  or  getting 
Notifications.  

Double-click on Task Group  

You can use RTF editor to support the task with 
related  instructions  or  details  that  will  be 
displayed in Notes panel at the bottom when the 
task  is  highlighted.  Also  you  can  format  the 
text's font name, size, color, style, etc.  

 Select Note tab 

 Enter Text 

 Format Text 

 Click OK  

Select Status of the Task 
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You can attach a Link or a File to the task. If you 
select Link, it will connect the task with a page in 
the  Internet  or  a  file  stored  at  your  PC  or  in  a 
shared folder in the Local Network. If  you select 
File,  it  will  automatically  upload  a  file  to  the 
database.  The  attachments  will  be  displayed  in 
Attachments panel at the bottom, when the task is 
highlighted.  

 Select Attachments tab 

 Click on Add Attachment button 

Select Link or File Enter hyperlink or file location Enter description for attachment, 

click  OK 

Users  can  easily  open  the  files  or  Internet  pages  and  save  files  from  Database  to  their  PC's  or  to  shared 
folders of other PC's in the Local Network (saving is possible only after you have clicked on  OK  and saved 
the task). 
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Select a Link or File and click on Open Attachment 

 Select a Link or File and click on Save Attachment 
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2.2.2. Planning Resources 

Users  can  assign  a  resource  or  several  resources  to  the  task  only  if  they  are  granted  Administration 
Permissions (see Setting Resources).  Also users can assign to tasks only those Resources which are granted 
Assignment Permission (see Setting Resources). If a Resource is not granted Assignment Permission it will 
not be displayed in the list of this window. 

 Select Resource tab 

 Check Resource(s)  

 Click  Ok 
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2.2.3. Planning Time 

While scheduling a Task you can estimate the time this Task can take and make a more realistic timetable. 
If the task should be done by a certain deadline you can set its Due Date. 

Select  Estimated Time  from drop-down menu   

Check Due Date and select a calendar date 
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If a Task should begin at a certain time and finish at a certain time you can set Start and Finish Date and 
Time. 

Check Date&Time and select Start Date and Time, select Finish Date and Time 

 Click on Recurrence button and set recurring Tasks 
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If you want to remind yourself or your team member of a Task, you can define the exact time of pop-up or 
the time period before Start, Finish or Due Date and then select the Resource(s) to be reminded of the Task.  

Select Reminder tab and set Reminder 

Check  Resources  to be reminded of the Task 
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2.3. Step 3. Communication 

2.3.1. Sending & Receiving Notifications 

The program can automatically send notifications to all concerned with the task. In case you don't want a 
task notification to be sent automatically you should select a status where notification mode is turned off, 
like Draft Status (see Setting Workflow).  

Notifications can be sent  each time there  is  a  change in  the task's  attributes,  like Name,  Priority,  Status, 
Due  Date,  Start  Time,  Finish  Time,  Reminder,  Attachment,  Note,  etc.  Notifications  panel  displays 
received notifications which are checked for each Resource individually in Notifications tab of Resource 
dialog (see Setting Resources) 

Notifications panel at the left bottom of the screen 

Notification panel allows users to mark selected or all the Notifications as read.   

Select a Notification and click on  Mark As Read 

  

                   Click on  Mark All As Read 

Also users can filter Notifications to display those you haven't read yet or display only those Notifications 
that belong to a highlighted Task. 
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Click on Show UnRead button  Click on Show Notifications of Highlighted Task 

When users activate Notification Description they will be able to see the Types of Notifications they are 
subscribed to and changes that took place in Task attributes, such as Status, Assigned Resource, Start and 
Finish Date, Priority, etc. If they want to see the Task on the list they can highlight it there by click on Find 
task button  

Click on Show Description button 

Click on Find Task button                 
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2.4. Step 4. Management 

2.4.1. To Do List Management 

VIP Task Manager allows you to manage your company or your team to do lists,  projects and schedules. 
All three tools are interconnected so you create a task and manage it in Task List, Task Tree and Calendar 
view.  

Task List view shows you Tasks as a 'to do list'. It is very useful and powerful time and task management 
tool for prioritizing, sorting, grouping tasks.  

Select a task, click on Increase Priority button Click on Manual Sorting and Move Up button 

Click on any column header to sort tasks    Drag & Drop a column header to group tasks  
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2.4.2. Project Management 

Task  Tree  view  shows  Task  Groups  and  Tasks  as  'projects'.  It  is  very  useful  and  powerful  project 
management  tool  for  creating  hierarchy of  Task  Groups  and  their  Tasks.  If  users  highlight  a  Task  Group 
they can easily create its Sub Groups and Tasks.   

Highlight a Task Group, click on New Folder button Highlight a Task Group, click on  New Task  button 
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2.4.3. Schedule Management 

Calendar view shows Tasks as 'schedule'.  It  is useful and powerful schedule management tool for making 
time tables of meetings, appointments and events.   

Select a date  

Select several dates 
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Users can create Tasks for the certain Dates and Time periods.    

 Select a Time Period 

Click on New Task button 

User can reschedule Task by dragging and dropping it all over the Schedule. 

Drag & Drop Task across the Schedule 
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2.5. Step 5. Tracking & Reporting 

2.5.1. Applying Filters 

After your employees or your team members received notifications about tasks assigned to them and started 
working  on  their  task,  they  can  update  the  tasks.  Once  they made  any  changes  in  tasks  you  will  receive 
notification about that as the task owner so you will be able to track your company progress. The program 
allows users to track Tasks status, % of accomplishment, time left till deadlines, actual time spent, etc. 

Database  may  contain  thousands  of  Tasks  so  we  strongly 
recommend all the users to apply filters that help to focus on actual 
tasks.  

You  can  set  filters  for  a  certain  Task  Group  you  or  your  team  is 
working on at the moment. 

 Select a Task Group in Task Groups panel             

 Click on Set Filter button 

Filters panel is a powerful tool to display tasks with a certain names, 
numbers,  statuses,  priority,  date  range,  owners  and  assigned 
resources.  

 Choose filter settings  

 Click on Apply Filter button 

If you use a certain combination of filters often you can save it and 
then choose it from the drop-down list.  
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2.5.2. Watch List 

If some Tasks don't relate to you directly, but you need to receive notifications of them, there are two ways:  

1. You can subscribe to notifications of Tasks assigned to certain Task Groups (folders) 

  
Select Watch List tab in Edit Task Group dialog 

2. You can subscribe to notifications of Tasks assigned to a certain Resources (users) 

Select Watch List tab in Edit Resource dialog 
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2.5.3. History 

You can track the history of all changes in Tasks from their creation to completion.  

 Select History tab in Edit Task Dialog 
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2.5.4. Customizing Views 

Users  can  customize  the  Task  List  and  Task  Tree  view  by  adding  columns  from  the  list  or  removing 
columns they don't need. 

Right-click on column header, select Remove This Column 

Users can customize Calendar view by adding or removing Resources Schedules, displaying Schedules for 
various time periods, changing Time Interval.  

Display more or less Resources Schedules 
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Select Weekly, Monthly or Yearly Schedule 

Change Time Interval 
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2.5.5. Exporting 

Users can export Task List and Task Tree view to HTML and MS Excel to add this information to their 
reports or publish on corporate website. 
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2.5.6. Printing 

Users can print Task List and Task Tree view to present reports, take to do lists out of office, etc.  
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3 User Interface 

3.1. Interface Summary 

Getting familiar with VIP Task Manager Professional Interface 

 Main Menu provides access to main features of the program 

 View tabs allow shifting between Task List, Task Tree, Calendar and Resource List views 

 Toolbars contain commands, specific for given panel or view 

 Panels feature various tools for managing tasks, task groups or resources  

  Grid  displays tasks, task groups or resources in the form of list, hierarchic structure or schedule 
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3.2. Main Menu 

Main Menu consists of: 
'File' menu 

'View' menu 

'Tools' menu 

'Help' menu 

‘File’ menu 
Inside ‘File’ menu the following options are available: 

 Change User  allows to login to the program under administrator or other user account   

 Edit User Profile allows to edit user information like Job Title, E-mail, Phone, etc. 

 Archive mode allows to show the tasks that are placed in archive 

 Edit  name  of  root  task  group  allows  to  change  the  name  of  root 

task group (only if you login under administrator account)  

 Export  View  to  Excel  allows  to  export  Task  List,  Task  Tree, 

Calendar and Resource List views to MS Excel 

 Export  View  to  HTML  allows  to  export  Task  List,  Task  Tree, 

Calendar and Resource List views to HTML 

 Import VPXML allows to import tasks from VIP Team To Do List 

software product 

 Import from Outlook  allows to import tasks, contacts, journals and 

appointments from MS Outlook 

 Print  allows  to  print  out  Task  List,  Task  Tree,  Calendar  and 

Resource List views 

 Print Preview allows to preview Task List, Task Tree, Calendar and 

Resource List views, create and edit your own print design 

 Exit allows to exit the program 

‘View’ menu 

Inside ‘ View ’ menu the following options are available: 
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 Toolbars  option  allows  to  display,  hide  and  customize 
Toolbars of corresponding Views and Panels 

 Panels option allows to display or hide corresponding Panels 

 Columns option allows to display or hide columns on the grid 
of corresponding Views 

‘Tools’ menu 

Inside ‘Tools’ menu the following options are available: 

 Custom fields  option  allows  users  to  create,  edit  and  delete  their 
own fields  

 Custom  workflow  option  allows  user  to  create,  edit  and  delete 
their own types of workflow and task statuses within these types.  

 Options  allow  users  to  edit  various  program  settings  like  Global 
Hotkeys,  maximal  size  of  attachments,  loading  program  on 
Windows StartUp, etc. 

‘Help’ menu 

Inside ‘Help’ menu the following options are available: 

 Help  option allows users to make an acquaintance of program features and solve problems that  appear 
when working with the program  

 About option allows users to get information about product 
version and software company 

 Home page option allows users to open product home page 
in default Internet browser 

 Enter  license  information…  option  allows  users  to  enter 
the path to license file in order to register the product  
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3.3. Task List View 

Task List Toolbar 
By default Task List toolbar is located at the left top part of Task List view. 

The following table describes each of the Task List Toolbar buttons. 

Button Hot Key Description 

Ins Create a new task 

F4 Edit existing task 

F8 Delete existing task 

Shift + Ctrl + 
Down 

Decrease task priority 

Shift + Ctrl + Up Increase task priority 

Change task(s) status  

Ctrl + 0 Manual task sorting 

Ctrl + Up 
Move the task one position up (button is available if ‘Manual sorting’ 
button is activated) 

Ctrl + Down 
Move the task one position down (button is available if ‘Manual 
sorting’ button is activated) 

F5 Refresh the tasks on Task List grid  

Always expand all task groups when the tasks are grouped by any 
column 

Expand all task groups when the tasks are grouped by any column 
(available if ‘Always expand’ is not activated) 
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Collapse all task groups when the tasks are grouped by any column 
(available if ‘Always expand’ is not activated) 

None – hide tasks’ notes  and custom fields 
Note as plain – display tasks’ notes as plain text on Task List grid 
Note as RTF – display tasks’ notes as RTF on Task List grid 
Custom fields info – display tasks’ custom fields  

Ctrl + W Apply columns auto width 

Select the columns that will be visible on Task List grid 

Add or remove buttons to Task List Toolbar 

Tips: 

 To display or hide Task List Toolbar use main menu command [View -> Toolbars -> Task List]. 

To move Task List Toolbar move mouse cursor to its left border, left click on it while cursor has 
its ‘crosshair’ status, drag and drop it wherever you need 
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To take Task List Toolbar out its default 
location and vice versa double click on it.  

Task List grid 

Right click on the task allows to carry out following operations  
 Create a new task 
Edit selected task 
 Delete selected task 
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Make a copy of selected task 
Create next recurrence of the task 
Change the status of selected task  
Increase selected task priority 
Decrease selected task priority 
Select and apply existing filter to Task List grid 
Clear all filters on Task List grid 
Move selected task one position down in Task List grid 
Move selected task one position up in Task List grid 
Activate manual sorting of the tasks 
Move the task to archive 
Always  expand  all  task  groups  when  the  tasks  are 

grouped by any column 

Expand  all  task  groups  when  the  tasks  are  grouped  by 
any  column  (available  if  ‘Always  expand’  is  not 
activated) 

Collapse all  task groups when the tasks  are grouped by 
any  column  (available  if  ‘Always  expand’  is  not 
activated) 

Send the tasks by e-mail 
Print out selected task(s) 
Preview  Task  List  grid,  create  and  edit  your  own  print 

design 

Print out Task List grid 
Export Task List grid to Excel 
Export Task List grid to HTML 

Column headers 

Right click on column header allows to carry out following operations on Task List Grid 

Sort tasks in ascending order by selected 
column 

Sort tasks in descending order by selected 
column 

Clear sorting by selected column 
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Group tasks by selected column 
Display or hide the space above Task List grid that 

allows to group tasks using drag & drop method 

Display or hide Task List Grid footer 
Display or hide Task Group footers 
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Remove selected column from Task List grid 
Add or remove columns to Task List grid 

Align left selected column 
 Align right selected column 
Align center selected column 
 Set selected column best fit 
Set all columns best fit 

Left click on column header allows to sort tasks in ascending or descending order by selected column 
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Drag & Drop method applied to  column header allows to  carry out  following operations on Task List 
Grid 

 Replace selected column where you need 

  

            
 Group tasks by selected column 
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Left click on Current filter box allows to temporarily reset or apply current filter 

Grid Footer 
Right click on Task List grid footer under particular column allows to carry out following operations  

 Watch total value of selected task property, where it makes sense 
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 Watch minimum value of selected task property, where it makes sense 
 Watch maximum value of selected task property, where it makes sense 
 Watch the account of the tasks that are displayed on Task List grid 
 Watch average value of particular task property, where it makes sense 
 Hide all values from the footer under selected column 
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3.4. Task Tree View 

Task Tree Toolbar 
By default Task Tree toolbar is located at the left top part of Task Tree view.  

The following table describes each of the Task Tree Toolbar buttons. 

Button Hot Key Description 

Ins Create a new task 

Ctrl + G Create a new group 

F4 Edit existing task or group 

F8 Delete the task 

Apply or clear filter 

Shift + Ctrl + Down Decrease task priority 

Shift + Ctrl + Up Increase task priority 

Change task(s) status  

Ctrl + 0 Manual task sorting 

Ctrl + Up 
Move the task one position up in the task tree within its task group 
(button is available if ‘Manual sorting’ button is activated) 

Ctrl + Down 
Move the task one position down in the task tree within its task 
group (button is available if ‘Manual sorting’ button is activated) 

Display the tasks of all task groups on Task Tree grid  
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Roll up all tasks and task groups to the root group on Task Tree 
grid 

F5 Refresh the tasks on Task Tree grid 

None – hide tasks’ notes  and custom fields 
Note as plain – display tasks’ notes as plain text on Task List grid 
Note as RTF – display tasks’ notes as RTF on Task List grid 
Custom fields info – display tasks’ custom fields  

Ctrl + W Apply columns auto width 

Select columns that will be visible on Task Tree grid 

Add or remove buttons to Task Tree Toolbar 

Tips: 
 To display or hide Task Tree Toolbar use main menu command [View -> Toolbars -> Task Tree]. 

 To move Task Tree Toolbar move mouse cursor to its left border, left click on it while cursor has its 
 ‘crosshair’ status, drag and drop it wherever you need. 

 To take Task Tree Toolbar out its default allocation and vice versa double click on it.  
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Task Tree grid 

Right click on the task or task group allows to carry out following operations  
 Create a new task 
Create a new task group 
 Edit selected task or task group (when clicking on task group) 
Delete selected task or task group (when clicking on task group) 
 Make a copy of selected task or task group (when clicking on task group) 
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Insert a copy of selected task group into current task group 
Create next recurrence of the task (is available only for 

tasks) 

Change the status of selected task (is available only for 
tasks) 

Increase  selected  task  priority  (is  available  only  for 
tasks) 

Decrease  selected  task  priority  (is  available  only  for 
tasks) 

Set  task  and  task  group  custom  fields  options  (is 
available only for task groups) 

Select and apply existing filter to Task Tree grid 
Clear all filters on Task Tree grid 
Move  selected  task  one  position  down within  its  task 

group or  move selected task group (when clicking on 
task group) one position down in Task Tree grid  

Move  selected  task  one  position  up  within  its  task 
group or  move selected task group (when clicking on 
task group) one position up in Task Tree grid 

Activate manual sorting of the tasks or task groups 
(when clicking on task group) 

Move the task or task group (when clicking on task 
group) to archive 

Expand all task groups  
Collapse all task groups  
Print out selected task(s) 
Preview Task Tree grid, create and edit your own print 

design 
Print out Task Tree grid 
Export Task Tree grid to Excel 
Export Task Tree grid to HTML 

Column headers 
Right click on column header allows to carry out following operations:  

Add or remove columns on Task Tree Grid 
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 Display or hide Task Tree Grid footer 
Apply columns auto width on Task Tree Grid 
 Apply column best fit on Task Tree Grid 

Left click on column header allows to sort tasks in ascending or descending order by selected column 
within the task groups 

Drag & Drop method applied to  column header allows to  replace selected column where you need on 
Task Tree Grid 
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3.5. Calendar View 

Calendar Toolbar 
By default Calendar toolbar is located at the left top part of Calendar view. 

The following table describes each of the Calendar Toolbar buttons. 

Button Hot Key Description 

Ins Create a new task 

F4 Edit existing task 

F8 Delete existing task 

Shift + Ctrl + Down Decrease task priority 

Shift + Ctrl + Up Increase task priority 

Change task(s) status  

F5 Refresh the tasks on Calendar grid  

Ctrl + 1 Display task daily schedule on Calendar grid 

Ctrl + 2 Display task weekly schedule on Calendar grid 

Ctrl + 3 Display task monthly schedule on Calendar grid 

Ctrl + 4 Display task yearly schedule on Calendar grid 

Ctrl + 5 Display tasks as rows and days as columns on Calendar grid 

Group tasks by resource on Calendar grid 

Select resources to display their tasks on Calendar grid 

Select Calendar grid time scale 

Select time interval to display tasks on Calendar grid 
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Add or remove buttons to Calendar Toolbar 

Tips: 
 To display or hide Calendar Toolbar use main menu command [View -> Toolbars -> Calendar]. 

 To move Calendar Toolbar move mouse cursor to its left border, left click on it while cursor has its ‘ 
crosshair’ status, drag and drop it wherever you need. 

 To take Calendar Toolbar out its default allocation and vice versa double click on it.  
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Calendar grid 

Right click on the Calendar grid empty space allows to carry out following operations  
Create a new task 
Display today’s schedule on Calendar grid 

Display  this  particular  date’s  schedule  (available  only 
when weekly, monthly or yearly view is displayed) 

Enter  required  date  and  watch  its  schedule  on  Calendar 
grid 

Group task schedules by resources on Calendar 
 Select and apply existing filter to Calendar grid 
Clear all filters on Calendar grid 
 Preview  Calendar  grid,  create  and  edit  your  own  print 

design 
 Print out Calendar grid 

Export Calendar grid to Excel 
 Export Calendar grid to HTML 

Right click on the task on Calendar grid allows to carry out following operations  
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Create a new task 
Edit selected task 
Delete selected task 
Make a copy of selected task 
Create next recurrence of the task 
Change the status of selected task  
Increase selected task priority 
Decrease selected task priority 
Select and apply existing filter to Calendar grid 
Clear all filters on Calendar grid 
Move the task to archive 
Send the tasks by e-mail 
Print selected task(s) 
Preview  Calendar  grid,  create  and  edit  your  own 

print design 

Print out Calendar grid 
Export Calendar grid to Excel 
Export Calendar grid to HTML 

Right click on Time column allows to change schedule time interval on Calendar grid 

Left  click  on  ‘+’  and  ‘-’  buttons  allows  to  show  more  or  fewer  resources’  schedules  on  Calendar  grid 
accordingly. 

Left  click  on   and   buttons  allows  to  show  first  and  last  resource’s  schedules  on  Calendar  grid 
accordingly. 
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Notes: 

 Tasks’ background color is orange if the task is overdue 

 Tasks with the different statuses may have different font colors (See How to create new task workflow) 
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3.6. Resource List View 

Resource List Toolbar 
By default Resource List toolbar is located at the left top part of Resource List view. 

The following table describes each of the Resource List Toolbar buttons. 

Button Hot Key Description 

Ins Create a new resource  

F4 Edit existing resource 

F8 Delete existing resource 

F5 Refresh tasks on Resource List grid  

Ctrl + W Apply columns auto width 

Add or remove columns on Resource List grid 

Add or remove buttons to Resource List Toolbar 

Tips: 
 To display or hide Resource List Toolbar use main menu command [View -> Toolbars -> Resource 

List]. 

 To move Resource List Toolbar move mouse cursor to its left side, left click on it while cursor has its 
‘crosshair’ status, drag and drop it wherever you need. 
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 To take Resource List Toolbar out its default location and vice versa double click on it.  

Resource List grid 
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Right click on the resource allows to carry out following operations: 
  

 Create a new resource 
 Edit selected resource 
 Delete selected resource 
 Delete all preset filters (is available only for 

administrator) 
 Preview Resource List grid, create and edit your own 

print design 
 Print out Resource List grid 
 Export Resource List grid to Excel 
 Export Resource List grid to HTML 

Column headers 
Right click on column header allows to carry out following operations on Resource List Grid 

Sort resources in ascending order by selected 
column 

Sort  resources  in  descending  order  by  selected 
column 

Clear sorting by selected column  
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Group resources by selected column 
Display or hide the space above Calendar grid 

that  allows  to  group  resources  using  drag  & 
drop method 

Display or hide Resource List Grid footer 
Display or hide Resource Group footers 



 

User Interface VIP Task Manager Pro 69 

 

Remove selected column from Resource List 
grid 

Add or remove columns to Resource List grid 

Align left selected column 
Align right selected column 
Align center selected column 
Set selected column best fit 
Set all columns best fit 

     

Left click on column header allows to sort resources in ascending or descending order by selected 
column 
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Drag & Drop method applied to column header allows to carry out following operations on Resource 
List Grid: 

 Replace selected column where you need 

  

 Group resources by selected column 
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Grid footer 
Right  click  on  Resource  List  grid  footer  under  particular  column  allows  to  carry  out  following 

operations  
 Watch total value of selected resource property, where it makes sense 
 Watch minimum value of selected resource property, where it makes sense 
 Watch maximum value of selected resource property, where it makes sense 
 Watch the account of the resources that are displayed on Resource List grid 
 Watch average value of particular resource property, where it makes sense 
 Hide all values from the footer under selected column 
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3.7. Task Groups Panel 

Task Groups panel features tools for creating, editing and deleting   task groups and subgroups on Task List 
and Calendar views. 

By default Task Groups panel is located in the left part of the Task List view under Task List Toolbar and in 
the left part of Calendar view under Filters panel. 

        

OR 

           

Tips: 
 To  display  or  hide  Task  Groups  panel  use  main  menu  commands  [View  ->  Panels  ->  Task  List  - 

Groups] and [View -> Panels -> Calendar - Groups].  
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 To move Task Groups panel drag it and drop where you need. There must be a gray frame that shows 
panel’s future location while dragging it. 

 To take Task Groups panel out its default location and vice versa double click on it.  
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Task   Groups   Toolbar 
By default Task Groups toolbar is located at the top part of Task Groups panel. 

The following table describes each of the Task Groups Toolbar buttons. 

Button Description 

Filter tasks on Task List grid by selected Task Group 

Create a new Task Group 

Edit existing Task Group 

Delete existing Task Group 

Refresh Task Tree 

Move selected task group one position down in Task 
Tree 

Move selected task group one position up in Task Tree 

Expand all task groups 

Collapse all task groups 

Add or remove buttons to Task Groups Toolbar 
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Tips: 
 To display or hide Task Groups Toolbar use main menu commands [View -> Toolbars -> Task Groups] 

and [View -> Toolbars -> Task Groups on Calendar View].  

 To move Task Groups Toolbar move mouse cursor to its left border, left click on it while cursor has its 
‘crosshair’ status, drag and drop it wherever you need. 

 To take Task Groups Toolbar out its default location and vice versa double click on it.  
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Task Groups Tree 

Right click on Task Groups grid allows to carry out following operations: 

Set filter to display tasks of selected task groups 
Reset filter 
Create a new task assigned to selected task group 
Create a new task group 
Edit selected task group 
Delete selected task group 
Insert the copy of task group into selected task group 
Make a copy of selected task group  
Set task and task group custom fields options 
Move selected task group one position up in Task Tree 
Move selected task group one position down in Task Tree 
Sort subgroups alphabetically within their task group  
Move selected task group to archive 
Expand all task groups 
Collapse all task groups 

Refresh Task Tree  

Tips: 

 Double click on  the space  near  Task Groups  panel’s  toolbar  allows  managing toolbars,  commands  and 
program options via Customize window 
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 To close the panel click on  button at its right bottom corner 

 To make the panel auto-hidden click on  button at its right bottom corner 

 To maximize the panel click on  button at its right bottom corner 

 To return the panel to its default position click on corresponding button again 



 

User Interface VIP Task Manager Pro 78 

 

3.8. Filters Panel 

Filters panel features tools for filtering tasks by their properties on Task List, Task Tree and Calendar views. 
By default Filters panel is located in the left part of views. 

                 

Tips: 
 To  display  or  hide  Filters  panel  use  main  menu  commands  [View  ->  Panels  ->  Task  List  -  Filters], 

[View -> Panels -> Task Tree - Filters] and [View -> Panels -> Calendar - Filters]. 
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 To move Filters panel drag it and drop where you need. There must be gray frame that shows panel’s 
future location while dragging it 

 To take Filters panel out its default location and vice versa double click on its title.  
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Filters Toolbar 
By default Filters toolbar is located at the top part of Filters panel. 

The following table describes each of the Filters Toolbar buttons. 

Button Description 

Select and apply predefined filter 

Apply filter (is enabled when “Automatic applying filter” isn’t activated) 

Clear Task List filter 

Save current filter 

Delete current filter 

Set automatic applying filter 

Add or remove buttons to Filter Toolbar 

Tips: 
 To display or hide Filters Toolbar use main menu commands [View -> Toolbars -> Filters-Task List], 

[View -> Toolbars -> Filters-Task Tree] and [View -> Toolbars -> Filters-Calendar]. 
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 To  move  Filters  Toolbar  move  mouse  cursor  to  its  left  border,  left  click  on  it  while  cursor  has  its  ‘ 
crosshair’ status, drag and drop it wherever you need. 

 To take Filters Toolbar out its default location and vice versa double click on it.  

Filters Fields 
Right click on Filter fields allows to carry out following operations: 
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 Select and apply existing filter to Task List, Task Tree and 
Calendar grids 

 Apply new filter to Task List, Task Tree and Calendar grids  
 Set automatic applying filter 
 Clear current filter 
 Delete current filter 
 Save current filter  

By dragging columns header border you can change columns’ width. 

Tips: 

 Double  click  on  the  space  near  Filter  panel’s  toolbar  allows  managing  toolbars,  commands  and 
program options via Customize window 
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 To close the panel click on  button at its right bottom corner 

 To make the panel auto-hidden click on  button at its right bottom corner 

 To maximize the panel click on  button at its right bottom corner 

 To return the panel to its default position click on corresponding button again 
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3.9. Notifications Panel 

Notifications  panel displays notifications of changes in task properties.  
By default Notifications panel is located at the left bottom part of application window. 

Tips: 
To display or hide Notifications panel use main menu command [View -> Panels -> Notifications]. 

To move Notifications panel drag it and drop where you need. There must be a gray frame that shows 
panel’s future location while dragging it 
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 To take Notifications panel out its default location and vice versa double click on its title.  

Notifications Toolbar 
By default Notification toolbar is located at the left top part of Notification panel. 
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The following table describes each of the Notifications Toolbar buttons. 

Button Description 

Check for new notifications 

Mark highlighted notification as read 

Mark all notifications as read 

Show only unread notifications 

Show notifications of highlighted task 

Show notifications description 

Open task of highlighted notification 

Find task of highlighted notification 

Set notifications filter by date created 

Add or remove buttons to Notifications Toolbar 

Tips: 
To display or hide Notifications Toolbar use main menu command [View -> Toolbars -> Notifications]  
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To move Notifications Toolbar move mouse cursor to its left border, left click on it while cursor has its  
‘crosshair’ status, drag and drop it wherever you need 

 To take Notifications Toolbar out its default location and vice versa double click on it.  

Notification grid 
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Left  click  on  column  header  allows  to  sort  notifications  in  ascending  or  descending  order  by  selected 
column 

Right click on Notifications grid allows to carry out following operations: 

 Find task of selected 
notification 

 Open  task  of 
selected notification 

 Check  for  new 
notifications 

 Mark  selected 
notification as read 

 Mark  all 
notifications as read 

 Show  notification 
description 

 Show  only  unread 
notifications 

 Show  notifications 

of highlighted task  

By dragging columns header border you can change columns’ width. 
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Tips: 

 Double click on the space near Notifications panel’s toolbar allows managing toolbars, commands and 
program options via Customize window 

 To close the panel click on  button at its right bottom corner 

 To make the panel auto-hidden click on  button at its right bottom corner 

 To maximize the panel click on  button at its right bottom corner 

 To return the panel to its default position click on corresponding button again 
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3.10.Notes Panel 

Notes panel  features tools for creating, editing and deleting task notes 
By default Notes panel is located at the right bottom part of application window. 

Tips: 
 To activate Notes panel select required task and press ‘Ctrl + Alt + N’ hot keys 
 To display or hide Notes panel use main menu command [View -> Panels -> Notes]. 

 To move Notes panel drag it and drop where you need. There must be a gray frame that shows panel’s 
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future location while dragging it 

 To take Notes panel out its default location double click on its tab.  

To return Notes panel to its default location double click on its title 
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Notes Toolbar 
By default Notes toolbar is located at the left top part of Notes panel. 

The following table describes each of the Notes Toolbar buttons. 

Button Hot key Description 

Ctrl + S Add a new note to task  

Cancel last changes of the note 

Preview highlighted task’s notes, create and edit your own print design 
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Print out highlighted task’s notes  

Ctrl + B Set text bold font 

Ctrl + I Set text italic font 

Ctrl + U Set text underlined font 

Alt + L Set text left alignment 

Alt + C Set text center alignment 

Alt + R Set text right alignment 

Set text font color 

Set text font name 

Set text font size 

Increase text font size one point 

Decrease text font size one point 

Add or remove buttons to Notes Toolbar 

Tips: 
 To display or hide Notes Toolbar use main menu command [View -> Toolbars -> Notes]. 

 To  move  Notes  Toolbar  move  mouse  cursor  to  its  left  border,  left  click  on  it  while  cursor  has  its  ‘ 
crosshair’ status, drag and drop it wherever you need. 
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 To take Notes Toolbar out its default location and vice versa double click on it.  

Notes entry field 

Right click on Notes entry field allows to carry out following operations: 
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Undo last operation 
Redo last operation 
Cut selected text 
Copy selected text 
Paste selected text in required 

place of Notes grid 
Delete selected text 
Select all text 

Tips: 

 Double  click  on  the  space  near  Notes  panel’s  toolbar  allows  managing  toolbars,  commands  and 
program options via Customize window 

 To close the panel click on  button at its right bottom corner 

 To make the panel auto-hidden click on  button at its right bottom corner 

 To maximize the panel click on  button at its right bottom corner 

 To return the panel to its default position click on corresponding button again 
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3.11.Comments Panel 

Comments panel  features tools for adding comments to task 
By default Comments panel is located at the right bottom part of application window.                                     

                                                      

Tips: 
To activate Comments panel select required task and press ‘Ctrl + Alt + C’ hot keys 
To display or hide Comments panel use main menu command [View -> Panels -> Comments]. 

To move Comments panel drag it and drop where you need. There must be a gray frame that shows 
panel’s future location while dragging it 
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To take Comments panel out its default location double click on its tab.  

To return Comments panel to its default location double click on its title 



 

User Interface VIP Task Manager Pro 98 

 

Comments Toolbar 
By default Comments toolbar is located in the middle of Comments panel above the comments entry 

field. 

The following table describes each of the  Comments Toolbar  buttons. 

Button Hot key Description 

Ctrl + S Add new comment to task comments section 

Cancel last changes of the note 

Preview Comments grid contents, create and edit your own print design 

Print out Comments grid contents 

Switch comment panel layout from horizontal to vertical and vice versa 

Sort the comments in ascending order of the date 
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Sort the comments in descending order of the date 

Ctrl + B Set text bold font 

Ctrl + I Set text italic font 

Ctrl + U Set text underlined font 

Alt + L Set text left alignment 

Alt + C Set text center alignment 

Alt + R Set text right alignment 

Enter the text in form of bullet list 

Decrease text font size one point  

Increase text font size one point  

Set text font size 

Set text font color 

Add or remove buttons to Comments Toolbar 

Tips: 
 To display or hide Comments Toolbar use main menu command [View -> Toolbars -> Comments]. 
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To move Comments Toolbar move mouse cursor to its left border, left click on it while cursor has its ‘ 
crosshair’ status, drag and drop it wherever you need. 

 To take Comments Toolbar out its default location and vice versa double click on it.  

Comments grid 

Right click on Comments grid allows to carry out following operations: 

 Sort the comments in ascending order of the date 
 Sort the comments in descending order of the date 
 Copy all comments 
 Print out Comments grid contents 
 Preview  Comments  grid  contents,  create  and  edit  your 

own print design 
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Comments entry field 

Right click on Comments entry field allows to carry out following operations: 

Undo last operation 
Redo last operation 
Cut selected text 
Copy selected text 
Paste selected text in required place of Notes grid 
Delete selected text 
Select all text 

Tips: 

 Double click on the space near Comments panel’s toolbar allows managing toolbars, commands and 
program options via Customize window 

 Double click on Comments splitter allows to display or hide comments entry field 
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 To close the panel click on  button at its right bottom corner 

 To make the panel auto-hidden click on  button at its right bottom corner 

 To maximize the panel click on  button at its right bottom corner 

 To return the panel to its default position click on corresponding button again 
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3.12.Resource Assignment Panel 

Resource Assignment panel  features tools for creating, editing and deleting resources and assigning them 
to tasks 

By default Resource Assignment panel is located at the right bottom part of application window. 

Tips: 
 To display or hide Resource Assignment panel use main menu command [View -> Panels -> Resource 

Assignment]. 

 To move Resource Assignment panel drag it and drop where you need. There must a be gray frame that 
shows panel’s future location while dragging it 
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 To take Resource Assignment panel out its default location double click on its tab.  

To return Resource Assignment panel to its default location double click on its title 



 

User Interface VIP Task Manager Pro 105 

 

Resource Assignment Toolbar 
By default Resource Assignment toolbar is located at left top part of Resource Assignment panel. 

The following table describes each of the  Resource Assignment Toolbar  buttons. 

Button Description 

Create a new resource 
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Edit selected resource 

Delete selected resource 

Add resource information fields to Resource Assignment panel 

Add or remove buttons to Resource Assignment Toolbar 

Tips: 
 To  display  or  hide  Resource  Assignment  Toolbar  use  main  menu  command  [View  ->  Toolbars  -> 

Resource Assignment]. 

 To  move  Resource  Assignment  Toolbar  move  mouse  cursor  to  its  left  border,  left  click  on  it  while 
cursor has its ‘crosshair’ status, drag and drop it wherever you need. 

 To take Resource Assignment Toolbar out its default location and vice versa double click on it.  
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Resource Assignment   grid 

Left click on column header allows to sort resources in ascending or descending order by selected column 

 Right click on Resource Assignment grid allows to carry out following operations 
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Create a new resource 
Edit selected resource 
Delete selected resource 
Delete all preset filters (is available only for administrator) 

By dragging columns header border you can change columns’ width. 

Tips: 

 Double  click  on  the  space  near  Resource  Assignment  panel’s  toolbar  allows  managing  toolbars, 
commands and program options via Customize window 

 To close the panel click on  button at its right bottom corner 
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 To make the panel auto-hidden click on  button at its right bottom corner 

 To maximize the panel click on  button at its right bottom corner 

 To return the panel to its default position click on corresponding button again 
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3.13.Attachments Panel 

Attachments panel  features tools for adding, opening, saving and deleting attachments 
By default Attachments panel is located at the right bottom part of application window. 

Tips: 
 To display or hide Attachments panel use main menu command [View -> Panels -> Attachments]. 

 To move Attachments panel drag it and drop where you need. There must be a gray frame that shows 
panel’s future location while dragging it 
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 To take Attachments panel out its default location double click on its tab.  

To return Attachments panel to its default location double click on its title. 
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Attachments Toolbar 
By default Attachments toolbar is located at left top part of Attachments panel. 

The following table describes each of the Attachments Toolbar buttons. 

Button Description 

Add a new attachment to selected task 

Edit selected attachment 

Delete selected attachment 

Open selected attachment  

Save attachment to your hard drive disk 
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Add or remove buttons to Attachments Toolbar 

Tips: 
 To display or hide Attachments Toolbar use main menu command [View -> Toolbars -> Attachments]. 

 To move Attachments Toolbar move mouse cursor to its left border, left click on it while cursor has its ‘ 
crosshair’ status, drag and drop it wherever you need. 

 To take Attachments Toolbar out its default location and vice versa double click on it.  
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Attachments   grid 

Left click on column header allows to sort resources ascendingly or descendingly by selected column 

Right click on Attachments grid allows to carry out following operations 
 Add a new attachment 
Edit selected attachment 
 Delete selected attachment 
Open selected attachment 
 Save selected  attachment  to  your  hard 

disc   

By dragging columns header border you can change columns’ width. 
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Tips: 

 Double click on the space near Attachments panel’s toolbar allows managing toolbars, commands 
and program options via Customize window 

 To close the panel click on  button at its right bottom corner 

 To make the panel auto-hidden click on  button at its right bottom corner 

 To maximize the panel click on  button at its right bottom corner 

 To return the panel to its default position click on corresponding button again 
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3.14.Task History Panel 

Task History panel  displays changes of the task and its properties 
By default Task History panel is located at the right bottom part of application window. 

Tips: 
 To display or hide Task History panel use main menu command [View -> Panels -> Task history]. 

 To move Task History panel drag it and drop where you need. There must be a gray frame that shows 
panel’s future location while dragging it 



 

User Interface VIP Task Manager Pro 117 

 

 To take Task History panel out its default location double click on its tab.  

To return Task History panel to its default location double click on its title. 

Task History Toolbar 
By default Task History toolbar is located at the left top part of Task History panel. 
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The following table describes each of the Task History Toolbar buttons. 

Button Description 

Print out Task History contents  

Preview Task History contents, create and edit your own print design 

Add or remove buttons to Task History Toolbar 

Tips: 
 To  display  or  hide  Task  History  Toolbar  use  main  menu  command  [View  ->  Toolbars  ->  Task 

history]. 

 To move Task History Toolbar move mouse cursor to its left border, left click on it while cursor 
has its ‘crosshair’ status, drag and drop it wherever you need. 
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 To take Task History Toolbar out its default location and vice versa double click on it.  

Tips: 

 Double click on the space near Task History panel’s toolbar allows managing toolbars, commands and 
program options via Customize window 
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 To close the panel click on  button at its right bottom corner 

 To make the panel auto-hidden click on  button at its right bottom corner 

 To maximize the panel click on  button at its right bottom corner 

 To return the panel to its default position click on corresponding button again 
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3.15.Permissions Panel 

Permissions panel  features tools for  granting or  denying users permissions to  see,  create,  edit  and delete 
tasks and task groups 

By default Permissions panel is located at the right bottom part of application window. 

Tips: 
To display or hide Permissions panel use main menu command [View -> Panels -> Permissions]. 

To move Permissions panel drag it and drop where you need. There must be a gray frame that shows 
panel’s future location while dragging it 
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To take Permissions panel out its default location double click on its tab.  

To return Permissions panel to its default location double click on its title. 
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Permissions Toolbar 
By default Permissions toolbar is located at left top part of Permissions panel. 

The following table describes each of the Permissions Toolbar buttons. 

Button Description 

Inherit permissions from parent role 

Grant selected permission to corresponding role 

Deny selected permission to corresponding role 

Add or remove buttons to Permissions Toolbar 
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Tips: 
To display or hide Permissions Toolbar use main menu command [View -> Toolbars -> Permissions]. 

To move Permissions Toolbar move mouse cursor to its left border, left click on it while cursor has its 
‘crosshair’ status, drag and drop it wherever you need. 

To take Permissions Toolbar out its default location and vice versa double click on it.  
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Permissions grid 

Left click on Roles column header allows to sort roles in ascending or descending order. 

Right click on Permissions grid allows to carry out following operations: 
 Inherit permissions from 

parent role 
 Grant  selected  permission 

to corresponding role  
 Deny  selected  permission 

to corresponding role  

By dragging columns header border you can change columns’ width. 

Tips: 

 Double  click  on  the  space  near  Permissions  panel’s  toolbar  allows  managing  toolbars,  commands 
and program options via Customize window 
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 To close the panel click on  button at its right bottom corner 

 To make the panel auto-hidden click on  button at its right bottom corner 

 To maximize the panel click on  button at its right bottom corner 

 To return the panel to its default position click on corresponding button again 
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3.16.Date Navigator Panel 

Date Navigator panel allows to select date to display its schedule on Calendar grid 
By default Date Navigator panel is located in the left top part of Calendar under Calendar Toolbar. 

Tips: 
 To display or hide Date Navigator panel use main menu command [View -> Panels -> Date Navigator]. 

 To move Date Navigator panel drag it and drop where you need. There must be a gray frame that shows 
panel’s future location while dragging it 
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 To take Date Navigator panel out its default location and vice versa double click on its title.  

Tips: 

 To close the panel click on  button at its right bottom corner 

 To make the panel auto-hidden click on  button at its right bottom corner 

 To maximize the panel click on  button at its right bottom corner 

 To return the panel to its default position click on corresponding button again 
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3.17.Roles Panel 

Roles panel features tools for managing roles and assigning them to resources 
By default Roles panel is located in the left part of Resource List view under Resource List Toolbar. 

Tips: 
 To display or hide Roles panel use main menu command [View -> Panels -> Roles]. 
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 To move Roles panel drag it and drop where you need. There must be a gray frame that shows panel’s 
future location while dragging it 

 To take Roles panel out its default location and vice versa double click on its title.  

Roles Toolbar 
By default Roles toolbar is located at the left top part of Roles panel. 

The following table describes each of the Roles Toolbar buttons. 
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Button Description 

Create a new role 

Edit selected role 

Delete selected role 

Add or remove buttons to Roles Toolbar 

Tips: 
 To display or hide Roles Toolbar use main menu command [View -> Toolbars -> Roles]. 

 To  move  Roles  Toolbar  move  mouse  cursor  to  its  left  border,  left  click  on  it  while  cursor  has  its  ‘ 
crosshair’ status, drag and drop it wherever you need. 

 To take Roles Toolbar out its default location and vice versa double click on it.  
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Roles Grid 

Left click on column header allows to sort roles in ascending or descending order by selected column 

Right click on Roles grid allows to carry out following operations 

Create a new role 
Edit selected role 
Delete selected role 

Tips: 

 Double  click  on  the  space  near  Roles  panel’s  toolbar  allows  managing  toolbars,  commands  and 
program options via Customize window 
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 To close the panel click on  button at its right bottom corner 

 To make the panel auto-hidden click on  button at its right bottom corner 

 To maximize the panel click on  button at its right bottom corner 

 To return the panel to its default position click on corresponding button again 
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3.18.Charts panel 

Charts  panel displays field’s values of the tasks in the form of diagram.  
By default Charts panel is located at the right bottom part of application window. 

Tips: 
 To display or hide Charts panel use main menu command [View -> Panels -> Charts]. 
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 To move Charts panel drag it and drop where you need. There must be a gray frame that shows panel’s 
future location while dragging it 

 To take Charts panel out its default location double click on its tab.  

To return Charts panel to its default location double click on its title. 
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Charts Toolbar 
By default Charts toolbar is located at the left top part of Charts panel. 

The following table describes each of the  Charts Toolbar  buttons. 

Button Description 

Print out the diagrams  

Preview the diagrams, create and edit your own print design 

Select the field for creating the first diagram 

Select the field for creating the second diagram 

Select the type of calculation that should be displayed on the diagram 
  

Add or remove buttons to Chart Toolbar 
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Tips: 
 To display or hide Charts Toolbar use main menu command [View -> Toolbars -> Charts]. 

 To move Charts  Toolbar  move mouse cursor  to  its  left  border,  left  click on it  while  cursor  has  its  ‘ 
crosshair’ status, drag and drop it wherever you need. 

 To take Charts Toolbar out its default location and vice versa double click on it.  
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Customization zone 

Customization zone is located under Charts toolbar. 

On the right of the Customization zone there is an option that allows to select column, bar, line, area or 
pie type of the diagram. 

Left click on “Customize Chart” button allows to display or hide diagrams, sort the data on the diagram 
in ascending or descending order, display or hide Data levels and set the appearance of the legend, titles 
and Customization zone. 
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“Data Levels” block allows to plot the diagrams for various values of the particular task fields by which 
the tasks are grouped on the grid.  
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The order of drill  down diagrams can be changed by Drag & Drop method. The level of displayed data 
can be changed by selecting required field on “Data Levels” box. 

Charts field 
Directing the cursor at the field of the diagram allows to watch the screen tips with the name of the field 
and the number of the tasks with each field value. Left click on the diagram allows to display the diagram 
of the following level, right click allows to return one level up.  

  

Tips: 

 Double  click  on  the  space  near  Charts  panel’s  toolbar  allows  managing  toolbars,  commands  and 
program options via Customize window 
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 To close the panel click on  button at its right bottom corner 

 To make the panel auto-hidden click on  button at its right bottom corner 

 To maximize the panel click on  button at its right bottom corner 

 To return the panel to its default position click on corresponding button again 
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4 User Manual 

4.1. Tasks 

4.1.1. How to create a new task 

There are several ways to create a new task. 
1. Click on “New Task” button on Task List, Task Tree or Calendar toolbar.  

2. Press “Ins” key 
3. Right click on Task List, Task Tree or Calendar grid and select “New Task” from drop-down list 

4. Double click on Task List, Task Tree or Calendar grid empty space 
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4.1.2. How to edit a task 

There are several ways to edit a task. 
1. Select required task and click on “Edit Task” button on Task List and Calendar toolbar or “Edit” button 

on Task Tree toolbar.  

2. Select required task and press “F4” key 
3. Right  click  on  required  task  on  Task  List  or  Task  Tree  grid  and  select  “Edit  Task”  or  “Edit” 

correspondingly from drop-down list 

4. Double click on selected task on Task List, Task Tree or Calendar grid 
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4.1.3. How to delete a task 

There are several ways to delete a task: 
1. Select required task and click on “Delete Task” button on Task List and Calendar toolbar or “Delete” 

button on Task Tree toolbar.  

2. Select required task and press “F8” key 
3. Select required task and press “Delete” key 
4. Right  click  on  required  task  on  Task  List,  Calendar  or  Task  Tree  grid  and  select  “Delete  Task”  or 

“Delete” correspondingly from drop-down list 

In confirmation window click “Ok” if you want to delete this task, or “No” if not. 
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4.1.4. How to set/change task priority 

To  set  task  priority  select  required  priority  from  “Priority”  drop-down  list  in  “New  Task”  dialog  while 
creating a new task. 

To change task priority use one of the following ways.  
1. Open “Edit Task” dialog and select required priority from “Priority” drop-down list 

2. Select required task and click on “Decrease Priority” / “Increase Priority” buttons on Task List, Task 
Tree or Calendar toolbar  
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3. Right click on required task on Task List, Task Tree or Calendar grid and select “Decrease Priority” 
/ “Increase Priority” from drop-down list 

4. Select required task and press “Shift + Ctrl + Up” / “Shift + Ctrl + Down” keys 

To change the priority of several tasks simultaneously select each of them while holding “Shift” key and 
change the priority using one of the ways mentioned above. 
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4.1.5. How to set/change task group 

To set task group select the name of required task group from “Task Group” drop-down box in “New Task” 
dialog and click “Ok” button while creating a new task. 

To change task group follow the steps: 
1. Open “Edit Task” dialog and select the name of required task group from “Task Group” drop-down 

box 
2. Click “Ok” button 
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Alternatively, use following ways to change task group: 
1. By drag & drop method replace the task from Task List or Calendar grid to required task group on 

Task Groups Panel 

2. By drag & drop method replace the task on Task Tree grid to required task group 



 

User Manual VIP Task Manager Pro 149 

 

4.1.6. How to set/change task Estimated or Actual Time 

To  set  task  Estimated  or  Actual  time  select  required  time  from  “Estimated  Time”  or  “Actual  Time” 
drop-down lists correspondingly in “New Task” dialog while creating a new task. 

If there is no required time in drop-down list enter the time in minute format using the keyboard 

To change task Estimated or Actual Time follow the steps: 
1. Open “Edit Task” dialog  
2. Select required Estimated or Actual time from “Estimated Time” or “Actual Time” drop-down lists 

correspondingly  
3. If there is no required time in drop-down list enter the time in minute format using the keyboard 
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4.1.7. How to set/change task status 

To set task status select required status from “Status” drop-down list in “New Task” dialog while creating a 
new task. 

To change task status use one of the following ways: 
1. Open “Edit Task” dialog and select required status from “Status” drop-down list 

2. Right click on required task on Task List, Task Tree or Calendar grid and select required status from 
“Change Status” drop-down list 
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4.1.8. How to set/change task Due Date 

To set task Due Date check “Due Date” option and select required date from “Due Date” drop-down list in 
“New Task” dialog while creating a new task. Alternatively, enter task Due Date using the keyboard. 

To change task Due Date open “Edit Task” dialog and repeat the actions mentioned above. 
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Tips: 

 To quickly select today’s date click on “Today” button in “Due Date” drop-down box 

 To clear Due Date entry field click on “Clear” button in “Due Date” drop-down box 
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4.1.9. How to set/change task Completion 

To set task completion enter required completion value in “Complete” entry field using up-down buttons in 
“New Task” dialog. 

Alternatively, enter required completion value using keyboard. 
To change task completion value open “Edit Task” dialog of the required task, open and repeat the actions 

mentioned above. 

Note: 

 When task completion value is changed from "'0" to "1", this day date appears in the "Date Started" 
column 

 When  task  status  is  changed  to  “Completed”,  its  finish  date  automatically  appears  in  the  “Date 
Completed” column. 
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4.1.10.How to set/change task Start and Finish Date 

To set task Start and Finish Date use following steps while creating a new task: 
1. Open “New Task” dialog 
2. Check “Date & Time” option  
3. Select  required  date  from  “Start  Time”  and  “Finish  Time”  drop-down  boxes  or  enter  it  using  the 

keyboard 
4. Using up-down buttons set Start and Finish time 
5. Check “All Day” option to set only date without time 

To  change  task  Start  and  Finish  Date  of  already  existing  task,  open  “Edit  Task”  dialog  of  this  task  and 
repeat the actions mentioned above. 
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4.1.11.How to set task recurrence 

To set task recurrence use following steps: 

1. Open “New Task” or “Edit Task” dialog 
2. Check “Date & Time” option and click “Recurrence…” button 
3. In  “Edit  Recurrence”  dialog  use  up-down  buttons  or  keyboard  to  set  task  start  and  finish  time  or 

select required task accomplishing duration from “Duration” drop-down list 
4. Set task recurrence interval (Daily, Weekly, Monthly, Yearly, Every Weekday or enter required day 

interval) 
5. Set task recurrence start date using “Start” drop-down box or keyboard 
6. Set task recurrence finish date (it  may be unlimited,  after required number of  recurrences  or  exact 

date) 
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To cancel task recurrence click “Remove recurrence” button. 
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4.1.12.How to set task reminder 

To set task reminder use following steps: 
1. Open  “New Task” or “Edit Task” dialog 
2. Select  “Reminder”  tab  and  check 

“Reminder” option 
3. If you want to be reminded at exact date and 

time check “At” radio-button, enter required 
date  and  time  using  drop-down  box  and 
up-down  buttons  or  keyboard 
correspondingly 

4.  If you want to be reminded before exact date 
and time check “Before” radio-button, select 
“Start  Time”,  “Finish  Time”  or  “Due  Date” 
from  drop-down  list  and  select  interval  you 
want  to  be  reminded  before  from 
corresponding drop-down list 

5.   Select resources to be reminded about this task from “Resources” drop-down box.  

To quickly select owner resource click   button, to quickly select resources this task is assigned to click 

  button, to  quickly select  all  resources click   button, to  clear  all  fields of  resource list  click  
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button. 

To cancel task reminder uncheck “Reminder” option. 
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4.1.13.How to assign the task to particular resource(s) 

To assign the task to particular resource(s) use following steps: 
1. Open “New Task” or “Edit Task” dialog 
2. Select “Resources” tab 
3. Select resources you want the task assign to from resource list 

Alternatively, drag required task and drop it to required resource on Resource Assignment panel. 
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4.1.14.How to attach files or links to the task 

To attach files or links to the task use the following steps: 
1. Open “New Task”  or “Edit Task” dialog 
2. Select “Attachments” tab 

3. Click  (“New attachment”) button or press “Ins” 
4. In “Edit  Attachment” dialog select  “File” or  “Link” from “Type” drop-down list  to  attach  files  or 

links correspondingly 
5. Enter file path or link URL into “URL” entry field or choose required file manually by clicking on 

 button 
6. Enter required description to the attachment in “Description” entry field 
7. Click “Ok” 

Alternatively, drag required file on your PC and drop it to required task or use the following steps to attach 
files or links to the task: 

1. Go to Attachments panel 

2. Click  (“New attachment”) button on Attachments toolbar 
3. In  “Edit  Attachment”  dialog  select  “File”  or  “Link”  from “Type”  drop-down  list  to  attach  files  or 

links correspondingly 
4. Enter file path or link URL into “URL” entry field or choose required file manually by clicking on 

 button 
5. Enter required description to the attachment in “Description” entry field 
6. Click “Ok” 
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Tips: 

 To edit attachment select it and click on  (“Edit Attachment”) button or press “F4” key.  

 To delete attachment select it and click on  (“Delete Attachment”) button or press “Del” key.  

 To open  attachment  select  it  and  click  on   (“Open  Attachment”)  button,  double  click  on  this 
attachment or press “Ctrl + O” key. 

 To save attachment to your hard drive select it and click on  (“Save Attachment File”) button or 
press “Ctrl + S” key. 
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4.1.15.How to add notes to the task 

To add notes to the task use following steps: 
1. Open “New Task”  or “Edit Task” dialog and select “Note” tab or go to Notes panel 
2. Enter the notes 

3. Click “Ok” button in “Edit Task” dialog or  (“Apply”) button on Notes toolbar 

OR 

Tips: 

 To insert current date & time into the notes position the cursor in the required place of Notes panel 
and press "F5" key 

 To create your own text design use Note tab toolbar in “New Task” or “Edit Task” dialog or Notes 
panel toolbar 

 To preview task note section, create and edit your own print design click on   (“Print Preview”) 
button on Notes panel toolbar 
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 To print out task notes section click on  (“Print”) button on Notes panel toolbar 

 To display task notes as plain text under the task in Task List or Task Tree grid click on “Preview 
Mode” button on Task List or Task Tree toolbar and select “Note as plain” from drop-down list 

 To display task notes as RTF under the task in Task List or Task Tree grid click on “Preview Mode” 
button on Task List or Task Tree toolbar and select “Note as RTF” from drop-down list 

 To hide task notes from Task List or Task Tree grid click on “Preview Mode” button on Task List 
or Task Tree toolbar and select “None’ from drop-down list 
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4.1.16.How to add comments to the task 

To add comments to the task use following steps: 
1. Open “New Task” or “Edit Task” dialog and select “Comments” tab or go to Comments panel 
2. Enter the comments 

3. Click “Ok” button in “Edit Task” dialog or  (“Apply Comment”) button on Comments toolbar 

OR 

Tips: 

 To  insert  current  date  &  time  into  the  comments  position  the  cursor  in  the  required  place  of 
Comments panel and press "F5" key 

 To create your own text design use Comments tab toolbar in “Edit Task” dialog or Comments panel 
toolbar 
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 To preview task comments section, create and edit your own print design click on   (“Print 
Preview”) button on Comments panel toolbar 

 To print out task comments section click on  (“Print”) button on Comments panel toolbar 
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4.1.17.How to group tasks 

Tasks can be grouped by any column by several ways: 
1. If there is no grey space above the Task List grid, right click on column header and select “Group 

By Box” from drop-down list. Drag the required column header and drop it on the space above Task 
List grid. 

2. Right click on column header and select “Group By This Field” from drop-down list 
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If you want to group tasks by several fields simultaneously, group by each field step by step using one of 
the ways mentioned above. 



 

User Manual VIP Task Manager Pro 169 

 

4.1.18.How to track task history 

To track task history use following steps: 
1. Open “Edit Task” dialog 
2. Select “History” tab 
3. Watch task history in the “List of changes” window 
4. Click “Ok”  

Alternatively, select required task and go to Task History panel. 

Tips: 

 To display task comments in task history click on  button (“Show comments”).  

 To print  out  task  history  and  create  your  own  print  design  select  required  task,  go  to  Task  History 
panel and click "Print task history" or "Preview..." buttons on Task History toolbar  
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4.1.19.How to sort tasks 

Tasks can be sorted within any column by several ways: 
1. Left  click on column header.  To change the  direction  of  sorting,  left  click  on  this  column header 

again. 
2. Right click on column header and select  “Sort  Ascending” or  ”Sort  Descending” from drop-down 

list 

OR 

      
To clear tasks sorting right click on column header and select “Clear Sorting” from drop-down list. 

Tasks can be sorted manually using following steps: 
1. Right click on Task List or Task Tree grid and select “Manual Sorting” from drop-down list or click 

on   button on Task List or Task Tree toolbar or press “Ctrl + O” key 
2. Select the task you want to replace 
3. Right click on Task List or Task Tree grid and select “Move Up”/”Move Down” from drop-down 

list or click on  /  buttons on Task List or Task Tree toolbar or press “Ctrl + Up” / “Ctrl + 
Down” keys 
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4.1.20.How to filter tasks 

Tasks can be filtered by any task group by several ways: 
1. Double click on required task group on Task Group panel 
2. Select required task group and click on “Set Filter” button on Task Group toolbar 

3. Right click on required task group and select “Set filter” from drop-down list 

Setting filter by the "Name" field 
To display the tasks with definite names or containing definite words in their names enter required name of 
the task or required words in “ Name”  entry field on Filters panel, click on “Apply Filter” button on Filters 
toolbar or press “Shift + Ctrl + T” keys. 

Setting filter by the "ID" field 
To display the tasks with definite id number enter required number of the task in “ ID”  entry field on Filters 
panel, click on “Apply Filter” button on Filters toolbar or press “Shift + Ctrl + T” keys. 
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Setting filter by the "Status" field 
To display the tasks with definite statuses select required statuses from “Status” drop-down box on Filters 
panel, click “Ok” and click on “Apply Filter” button on Filters toolbar or press “Shift + Ctrl + T” keys. 

Press  button to select everything and  button to clear.  

Setting filter by the "Priority" field 
To  display  the  tasks  with  definite  priorities  select  required  priorities  from  “Priority”  drop-down  box  on 
Filters panel, click “Ok” and click on “Apply Filter” button on Filters toolbar or press “Shift + Ctrl + T” 
keys. 
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Press  button to select everything and  button to clear.  

Setting filter by the "Actual Time" and “Estimated Time” fields 
To  filter  tasks  by  their  Estimated  or  Actual  time  select  “Estimated  Time”  or  “Actual  Time”  drop-down 
boxes on Filters panel correspondingly, from the first drop-down list select whether the time should equal, 
be  greater  or  less  than  the  value,  selected  from  second  drop-down  list,  click  “Ok”  and  click  on  “Apply 
Filter” button on Filters toolbar or press “Shift + Ctrl + T” keys. 
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Setting filter by the "Date Range"  
To filter tasks by their  Due or  Start  & Finish 
Date  select  “Date  Range”  drop-down  box  on 
Filters panel. 
If  you  want  to  filter  tasks  only  by  their  Due 
Date, only by their Start  & Finish Date or by 
Due  Date  and  Start  &  Finish  Date  select 
corresponding field from drop-down list. 

To  cancel  filter  by  this  field  that  was  set 
earlier check “None” radio button. 

To  display  the  tasks  with  Due  or  Start  & 
Finish Date relatively definite time or definite 
period  of  time  check  “Relative”  radio  button 
and select required date or period of time from 
corresponding drop-down list. 

To display the tasks with Due or  Start  & Finish Date by exact  date,  at  exact  time,  or  to  display all  tasks 
except exact date check “Date” radio button, select required field from “Equal” drop-down list and select 
required date in corresponding drop-down box. 
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To  display  the  tasks  with  Due  or  Start  &  Finish  Date  from  required  time  interval  check  “Range”  radio 
button and set required period of time with the help of drop-down time boxes.  
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If you want to display the tasks without Due or Start & Finish Date, check “Show empty date” option.  

Setting filter by the "Date Created",  "Date Last Modified", "Date Started" and "Date 

Completed" fields 
To quickly set a filter by the “Date Created”, “Date Last Modified”, “Date Started” or “Date Completed” 
fields, select “Date Created”, “Date Last Modified”, “Date Started” or “Date Completed” drop-down box 
correspondingly on Filters panel. 

To cancel filter by this field that was set earlier check “None” radio button. 

To display the  tasks  that  were  or  will  be  created,  last  modified,  started  or  completed  by definite  time  or 
during the definite period of time check “Relative” radio button and select required date or period of time 
from corresponding drop-down list. 

To display the tasks that were or will be created, last modified, started or completed by exact date, at exact 
time, or to display all tasks except exact date check “Date” radio button, select required field from “Equal” 
drop-down list and select required date in corresponding drop-down box. 
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To display the tasks with Date created, Date Last Modified, Date Started or Date Completed from required 
time interval check “Range ”  radio button and set required period of time with the help of drop-down time 
boxes.  

Then click “Ok” and click on “Apply Filter” button on Filters toolbar or press “Shift + Ctrl + T” keys. 

Setting filter by the "Owner" field 

To filter tasks by the task owner (the person who created the task), select required resources from “Owner” 
drop-down box on Filters panel, click “Ok” and click on “Apply Filter” button on Filters toolbar or press 
“Shift + Ctrl + T” keys. 

Setting filter by the "Assignment" field 

To filter tasks by the task assignment (the person who the tasks are assigned to), select required resources 
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from  “Assignment”  drop-down  box  on  Filters  panel,  click  “Ok”  and  click  on  “Apply  Filter”  button  on 
Filters toolbar or press “Shift + Ctrl + T” keys.   

Setting filter by the "Department" field 

To filter tasks by the employee’s department, select required departments from “Department” drop-down 
box on Filters panel, click “Ok” and click on “Apply Filter” button on Filters toolbar or press “Shift + Ctrl 
+ T” keys.   

Check ‘Yes’ radio button to view the tasks with empty “Department” fields or ‘No’ button vice versa. 

Setting filter by the Custom fields 

To filter tasks by custom field with “list” type, select required custom field in the list of Custom Fields on 
Filters panel, select required custom field values, click “Ok” and click on “Apply Filter” button on Filters 
toolbar or press “Shift + Ctrl + T” keys.   
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Check ‘ Yes’  radio button to view the tasks with empty custom fields or ‘ No’  button vice versa. 

To filter tasks by custom field with “integer” and “string” type, select required custom field in the list of 
Custom Fields  on  Filters  panel,  enter  required  custom  field  value  in  the  entry  field  and  click  on  “Apply 
Filter” button on Filters toolbar or press “Shift + Ctrl + T” keys.   

To filter tasks by custom field with “float”, “currency” or “duration” type, select required custom field in 
the list of Custom Fields on Filters panel, select how you want the tasks to be filtered, from drop-down list, 
click “Ok” and click on “Apply Filter” button on Filters toolbar or press “Shift + Ctrl + T” keys.   

To filter tasks by custom field with “date” or “date & time” type, select required custom field in the list of 
Custom Fields on Filters panel. 
To cancel filter by this field that was set earlier check “None” radio button. 
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To  display  the  tasks  with  required  custom  field  relatively  definite  time  or  definite  period  of  time  check 
“Relative” radio button and select required date or period of time from corresponding drop-down list. 

To display the tasks with required custom field relatively exact date or to display all tasks except exact date 
check  “Date”  radio  button,  select  required field  from “Equal”  drop-down list  and  select  required date  in 
corresponding drop-down box. 

To display the tasks with custom field value from required time interval  check “Range”  radio button and 
set required period of time with the help of drop-down time boxes.  

Then click “Ok” and click on “Apply Filter” button on Filters toolbar or press “Shift + Ctrl + T” keys. 

Tips: 

 To save the filter click on “Save filter as” button  

 To clear the filter click on “Clear Filter” button or Ctrl+F9  

 To delete current filter click on “Delete filter preset” button 

 To automatically apply filter click on “Automatic Applying Filter” button 
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4.1.21.How to export tasks 

There are several ways to export Task List, Task Tree and Calendar views to MS Excel or HTML. 
1. Select  required view,  select  main menu commands [File  |  Export  View To Excel…] or  [File  |  Export 

View To HTML…], enter export file name and path in “Export File Name” dialog. 

2. Right click on Task List, Task Tree or Calendar grid and select “Export View To Excel…” or “Export 
View To HTML…” from drop-down list, enter export file name and path in “Export File Name” dialog. 
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4.1.22.How to set task changes notifications 

The notifications of task changes are received by the owner of the task and the persons who are assigned to 
this task. 

To set task changes notifications for other employees use following steps: 
1. Open “New Task” or "Edit Task" dialog 
2. Select “Watch List” tab and check the resources who you want to receive the notifications about this 

particular task changes 
3. Click “Ok” button 

Tip: 

 If  a  task has  “Draft”  status,  the notifications  won’t  be sent.  In  order  that  required resources  receive 
notifications change task status from “Draft” to “Created”. 
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4.1.23.How to import tasks 

If you want to use VIP Team To Do List database, use following steps: 
1. Export  task  list  from  VIP  Team  To  Do  List  software  by  using  main  menu  command  [File  -> 

Export->Export  To  VPXML…].  Enter  database  name  and  path  in  “Enter  a  file  for  the  export 
operation” dialog 

2. Import  task  list  into  VIP  Task  Manager  software  product  by using main  menu command [File  -> 
Import VPXML…]. Find required file via “Open” dialog. 
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4.1.24.How to print out tasks 

There are several ways to print out Task List, Task Tree and Calendar views. 
1. Select required view, select main menu command [File -> Print…], enter print settings in “Print” 

dialog and click on “Print” button. 

  

2. Right click on Task List, Task Tree or Calendar grid and select “Print…” from drop-down list, enter 
print settings in “Print” dialog and click on “Print” button. 
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3. Press “Ctrl + P” keys. 

To print selected task(s) follow the steps below: 
1. Right click on Task List, Task Tree or Calendar grid and select “Print task(s)…” from drop-down list 

2. Select data sections that should be printed with the task in "Data sections:" box 

General  –  task  name,  priority,  task  group  this 
task  belongs  to,  Estimated  &  Actual  Time, 
Workflow, Status, Complete, Due Date, Start & 
Finish Date 
Assignments – the names of resources selected 
task is assigned to 
Attachments  –  the  types,  names  and 
descriptions of attachments of selected task 
Notes  – notes of selected task  
Comments – comments of selected task  
History – a history of task changes 
Custom  fields  –  names  and  values  of  custom 
fields selected task has 
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3. Set "RTF format" radio button 

4. Click "Build report" button 

You can preview Task List, Task Tree and Calendar views, create your own print design using several 
 ways: 

1. Select required view, select main menu command [File -> Print…], click on “Preview…” button in 
“Print” dialog. 
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2. Select required view and select main menu command [File -> Print Preview…]. 

3. Press “Shift + Ctrl + P” keys. 
4. Right  click on Task List,  Task Tree or  Calendar grid and select  “Print  Preview…” from drop-down 

list. 
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How to work with Print Preview Window 
To create your own print design, open Print Preview window and use following steps. 
1. Open “Format Report” dialog by using main menu command [File -> Design…], “Design Report” 

button on Print Preview toolbar, right click on the page or “Ctrl + D” keys 

OR OR 

2. In  “Format  Report”  dialog on  “View”  tab  check  corresponding  option  if  you  want  to  display  the 
report  with  column  headers,  footers,  group  footers  or  expand  buttons.  Preview  the  settings  in 
Preview window at the right part of “Format Report” dialog or click on “Apply” button to see the 
full screen preview. 
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3. In  “Format  Report”  dialog  on  “Behaviours”  tab  check  corresponding  option  if  you  want  to  print 
only selected  task,  expand all  groups or  set  report  size  equal  to  visible print  region  (alternatively 
right click on the page and select “Fit To Page” from drop-down list or select main menu command 
[Format->Fit  To  Page]  ).  Preview  the  settings  in  Preview  window  at  the  right  part  of  “Format 
Report” dialog or click on “Apply” button to see the full screen preview. 

4. In “Format Report” dialog on “Formatting” tab check corresponding option if you want to print one 
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group per page or select required style from “Look and Feel” drop-down list if you want to change 
it. Preview the settings in Preview window at the right part of “Format Report” dialog or click on 
“Apply” button to see the full screen preview. 

5. In “Format Report” dialog on “Styles” tab check “Use Native Styles” option if you want to change 
report style, select required object from corresponding list and select its Font, Colour and Texture 
using  corresponding  buttons.  Return  to  its  default  settings  or  save  new  style  using  “Restore 
Default” and “Save As…” buttons correspondingly. Preview the settings in Preview window at the 
right part of “Format Report” dialog or click on “Apply” button to see the full screen preview. 
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6. In “Format Report” dialog on “Preview” tab check “Visible” option if you want to print task notes, 
and “Auto Height” option to set line auto height. Preview the settings in Preview window at the 
right part of “Format Report” dialog or click on “Apply” button to see the full screen preview. 

7. In “Format Report” dialog check “Title Properties” button  or use main menu command [Format -> 
Title…] if you want to name the report, in “Report Title” dialog select whether your title will be on 
each page or only on first one from “Mode” drop-down list,  on “Text” tab enter required title, on 
“Properties” tab set title colour, font and alignment. 
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8. Click “Ok” 

To set up page properties open Print Preview window and use following steps: 
1. Open “Page Setup” dialog by using main menu command [File -> Page Setup], “Page Setup” button on 

Print Preview toolbar or right click on the page and select “Page Setup” from drop-down list 
  

OR   OR 

2. In “Page Setup” dialog on “Page” tab select required paper style, dimension, orientation, page source, 
print  order  and check corresponding option if  you want  to  print  using grey shading.  Click on “Print” 
button if you are ready to print. 
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3. In “Page Setup” dialog on “Margins” tab enter required margins’ values, check corresponding option to 
centre margins horizontally or vertically on page. To return to margins default values click on “Restore 
Original” button. Click on “Print” button if you are ready to print. 

4. In “Page Setup” dialog on “Header/Footer”  tab enter  left,  center  and  right  header  and  footer  titles  or 
select  predefined  information  from  “Predefined  Functions”  box,  set  headers’  and  footers’  font, 
background, vertical alignment. Click on “Print” button if you are ready to print. 
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5. In  “Page  Setup”  dialog  on  “Scaling”  tab  enter  percentage  page  scale  of  normal  size  by  checking 
“Adjust  To”  radio  button  and  selecting  required  value  in  corresponding  entry  field  with  the  help  of 
up-down buttons. To divide your task list into required amount of pages lengthways and in width check 
“Fit  To” radio button and enter  required values  in  corresponding entry fields  using up-down buttons. 
Click on “Print” button if you are ready to print 

You can display thumbnails in the left part of Print Preview Window using “Show Thumbnails” button on 
Print Preview toolbar, main menu command [View -> Thumbnails] or “Ctrl + U” keys. 
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If  you want  to  adjust  the page to  print  visible region  click on “Shrink to  Page”  button on Print  Preview 
toolbar. 

Using “Background” button on Print Preview toolbar, main menu command [Format -> Background…] or 
“Ctrl + K” keys you can change page background colour. 

Change the  scale  of  your  pages  with  the  help  of   “Zoom 100%”,  “Zoom  Page  Width”  buttons,  “Zoom” 
drop-down  list  on  Print  Preview  toolbar  or  “Ctrl  +  \”,  “Ctrl  +  o”  keys  correspondingly.  You  can  also 
display one, two, four or multiple pages on the screen using “Whole Page”, “Two Pages”, “Four Pages”, 
“Multiple  Pages”  buttons  on  Print  Preview  toolbar  or  “Ctrl  +  1”,  “Ctrl  +  2”,  “Ctrl  +  4”  keys 
correspondingly.  The  same  options  are  available  if  you  right  click  on  the  page  and  select  “Zoom” 
drop-down list. 

Left click on the page allows to decrease its scale from 100% to 50% and vice versa. 
 “Widen  to  source  width”,  “Ctrl  +  W”  or  corresponding  field  of  “Zoom”  drop-down  list  in  right  click 
contextual menu allow to adjust the scale to your screen to display the whole pages. 

To  go  to  the  first  (last)  or  previous  (next)  page  use  corresponding  buttons  on  Print  Preview  toolbar  or 
“Home”  (“End”)  and  “Page  Down”  (“Page  Up”)  keys  or  select  required  page  number  in  “Active  Page” 
field on Print Preview toolbar using up-down buttons. The same actions are available via “Go” main menu. 

If  you  don’t  need  margins  on  your  page,  go  to  main  menu  command  [File  ->  Options…]  and  uncheck 
“Margins” checkbox or use [View -> Margins] main menu command. 

OR 
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Save your report using main menu command [File -> Save…]. If you want to load already existing report, 
select main menu command [File -> Load…]  

To print the report use main menu command [File -> Print…] or “Ctrl + P” keys 

Close Print Preview Window using main menu command [File -> Close]. 
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4.1.25.How to create new task workflow 

To create new task workflow use the following steps: 
1. Select main menu command [Tools -> Custom workflow…]. 

2. Click on “New workflow” button on “Edit Workflow” dialog toolbar 

3. Enter  new  workflow  name  in  “New  workflow”  dialog.  Check  “Active”  option  if  you  want  your 
workflow to be active and click “Ok”. 

4. Click on “New Status” button on “Edit workflow” dialog toolbar or press “Ins” key. 
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5. In “Create Status” dialog enter new status name and check “Complete” option if you want to connect 
task status with % of task completion.  

To  connect  strong  %  value  with  this  status  check  “Strong  value”  radio  button  and  select  required  value 
from corresponding entry field  using up-down buttons  or  keyboard.  To  connect  the range of  percentages 
with this status select “Range” radio button and required percentage range from corresponding fields. 

To set  a  font  colour for this status  select  required colour  from corresponding drop-down list  or  find it  in 
“Color” drop-down box. 
To set font image for this status (.BMP 16x16 pixels) right click or double click on “Image” box and find 
required image file. 

In case you import a database from VIP Team To Do List you can associate the Status with the one from 
VPXML Status list by selecting required VPXML status from corresponding drop-down list.  

To turn on the notification mode for this status  select  “On” from corresponding drop-down list,  or  “Off” 
vice versa. 

Assign ID number for this status using “Value” entry field and up-down buttons. 
Check “Active” option if you want your status to be active and click “Ok”. 

To edit status select it and click on “Edit Status” button on “Edit Workflow” dialog toolbar or press “F4” 
key. 
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To delete status  select  it  and click on  “Delete Status” button on “Edit  Workflow” dialog toolbar  or  press 
“Del” key. 

To  move  status  select  it  and  click  on  “Status  Move  Up”  /  “Status  Move  Down”   buttons  on  “Edit 
Workflow” dialog toolbar or press “Ctrl + Up”/”Ctrl + Down” keys. 

The order of statuses that is set in “Edit Workflow” dialog will stay the same in “Status” drop-down list on 
“New  Task”  and  “Edit  Task”  dialogs  and  in  right  click  contextual  menu  of  Task  List,  Task  Tree  and 
Calendar grids. 
To edit workflow name select it and click on “Edit Workflow” button on “Edit Workflow” dialog toolbar. 
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To delete workflow select it and click on “Delete Workflow” button on “Edit Workflow” dialog toolbar. 
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4.1.26.How to create a new task custom field 

Custom field of the task may have one of the following types: 
· Integer  
· String  
· Date  
· Time  
· Date & Time  
· List 
· Currency  
· Float  
· Duration 

To create a new task custom field use following steps: 
1. Select main menu command [Tools -> Custom fields…]. 

2. Click on “New” button on “Edit custom fields” dialog toolbar or press “Ins” key. 

3. In “Edit Custom Field” dialog enter field title, code and select its type from “Type” drop-down list. By 
default custom field’s code will contain “cf_” prefix and custom field title, for example custom field ‘ 
Total’ will have “cf_Total” code. Code is  a unique identifier that  is  required for further calls  to this 
custom field.  
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Be careful while assigning custom field type. After you click “Ok” you won’t be able to change it. 

There are two ways of filling task custom field: its value can be entered by user and alternatively it can be 
calculated by some other task attributes and fields that were defined and assigned earlier. If custom field is 
calculated automatically, it can’t be entered by user and vice versa. 

How to programme formula 
Formula  is  described  in  “Formula”  entry  field.  Variables  and  functions  that  are  used  in  formula  must 
begin  with  “$”  symbol.  Formula  may  include  adding,  subtraction,  multiplication,  division, 
exponentiation, type conversion functions and “if” statement.  

Following table contains the operations that are available in formula: 

Operation Description 

+ Summation 

- Difference 

* Multiplication 

/ Division 

^ Exponentiation  

and The result of this operation is true if both operands are true 

or The result of this operation is true if at least one of the operands is 
true 

= Equal 

< Less  
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<= Less or equal 

> Greater  

>= Greater or equal 

Examples: 

If you want to programme  
3 

25 expression you should write 25^3. 
The result of the expression (25+10>30) or (5*3<15) is true. 
The result of the expression (45/9>6) and (12-3=9) is false. 

While carrying out any arithmetic operations, pay attention to their types and the type of obtained result. 
For example you can’t multiply two variables one of which has “date” type and other is integer. Or it’s 
impossible to assign float  variable to the field with “time” type.  All  formula’s  elements must have the 
same type. 

There are special functions to convert the variable of one type to another: 

Function Description 

ToInteger Convert any type variable to integer 

ToFloat Convert any type variable to real number 

ToDate Convert any type variable to date format 

ToTime Convert any type variable to time format 

ToDateTime Convert any type variable to date & time format 

ToString Convert any type variable to string 

If the argument of the function can’t be converted to required type, the result of this function work will 
be undefined or user will receive error message.  

Note: When string variable is used in formula, it should be written in double quotes. 

For example, if you want to sum up integer 41 and string “12”, you need to write 41+ToInteger(“12”).  

The syntax of “if” statement is following:  
iif(parameter1, parameter2, parameter3) 

parameter1 is any logical expression which result can be only true or false;  
parameter2 is  the value,  formula or  logical  expression that  will  be assigned to  this custom field  if  first 
parameter is true;  
parameter3 is  the value,  formula or  logical  expression that  will  be assigned to  this custom field  if  first 
parameter returns false.  

Types of the second and third parameters must be the same as current custom field type.  
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Enter custom field default value in accordance with its type into “Default value” field. 

You can set format for custom field values and their unit by using “Display format” field. For example, if 
you  want  to  display  custom  field  value  to  three  decimal  digits  and  its  unit  is  USD,  you  should  enter 
#0.000 USD. Custom field value will have only one decimal digit and EUR unit if display format is #0.0 
EUR. 

Check  corresponding  options  if  you  want  this  field  to  be  filtered,  grouped,  active  or  necessary  while 
creating a task and click “Ok”. 

To edit custom field select it and click on “Edit” button on “Edit custom fields” dialog toolbar or press 
“F4” key. 
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To delete custom field  select  it  and click on  “Delete”  button on “Edit  custom fields”  dialog  toolbar  or 
press “Del” key. 

To move custom field select it and click on “Move Up” / “Move Down” buttons on “Edit custom fields” 
dialog toolbar. 
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4.1.27.How to enter custom field values of the task 

To enter custom field values of the task use following steps: 
1. Open “New Task” or “Edit Task” dialog 
2. Select Custom Fields tab 
3. Enter required values by using the keyboard or up-down buttons or  select  custom field  values from 

predefined drop-down list according to the type of the custom field 
4. Click ‘Ok’  

Tips: 

 To display custom field  values  of  the task under  the task in  Task  List  or  Task Tree  grid  click on 
“Preview  Mode”  button  on  Task  List  or  Task  Tree  toolbar  and  select  “Custom  fields  info”  from 
drop-down list 

 To hide custom field values of the task from Task List or Task Tree grid click on “Preview Mode” 
button on Task List or Task Tree toolbar and select “None’ from drop-down list 
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4.1.28.How to place the task to archive and return it back 

In archive mode you can’t make any changes with the tasks. 
To place task to archive use following steps: 

1. Right click on required task on Task List, Task Tree or Calendar grids 
2. Select “Move to archive” from drop-down list  

OR 

OR 

After that selected task will disappear from your Task List.  
To return it from archive use following steps: 

1. Select main menu command [File -> Archive mode] 
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2. Right click on required task on Task List, Task Tree or Calendar grids 
3. Select “Restore from archive” from drop-down list 

OR 

OR 
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4.1.29.How to duplicate the task 

There are two ways to duplicate the task: 
1. Right click on required task on Task List,  Task Tree or  Calendar grid  and select  “Duplicate” from 

drop-down list 

2. Select required task and press “Ctrl + G” keys 
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4.1.30.How to create links to the tasks from other applications 

To place links to the tasks in other applications use following steps: 
1. Open the application where you want to create a link, e.g.  Microsoft Word, Excel, Outlook or other 

mail client 
2. In  the  place  where  you  want  to  insert  the  link  create  a  hyperlink  that  has  following  form: 

viptm:tid=<task ID>, e.g. viptm:tid=10 
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4.1.31.How to make graphic reports on the tasks 

To make graphic report on the tasks use following steps: 
1. Go to Task List or Calendar view and set filter to display required tasks 
2. Group the tasks by required fields 
3. Go to “Charts” panel 
4. Select required fields for the diagrams from the corresponding drop-down lists on Charts toolbar 

5. If  the  tasks  are  grouped  by  any  field  you  can  display  the  sum,  minimum,  maximum,  quantity  and 
average value for task field on the diagrams. Select required operation from corresponding drop-down 
list on Charts toolbar. 

6. Select required type of diagram from the drop-down list in the right upper part of Chart panel 

7. Click on “Customize Chart” button, check those diagrams that you want to display and uncheck the 
rest  ones.  From “Sort  by” drop-down list  select  the field  you want  the diagram to be sorted by and 
click on the button nearby to select the type of sorting – ascending or descending. 



 

User Manual VIP Task Manager Pro 213 

 

Select  “Data  Groups”  tab,  drag  data  level  that  you  want  to  hide  and  drop  it  to  the  empty space  on  “Data 
Groups” tab. To display data level that was hidden earlier, drag it on “Data Groups” tab and drop it where 
you need on “Data Levels” box. 

Select  “Options”  tab  and  set  required  appearance  for  diagram legend,  title  and  customization  zone.  If  you 
want  value  hints  to  be  shown  while  directing  the  cursor  to  the  diagram,  check  corresponding  option  on 
“Options” tab, or uncheck it otherwise.  
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8. “Data  Levels”  option  demonstrates  the  order  of  the  diagramed  fields.  To  change  their  order  drag 
required field’s title and drop it where you need on “Data Levels” box. 

  

For example,  the tasks  in  your  list  are  grouped by “Priority”  and “Complete” fields.  In  “Data  Levels” box 
you will see the same sequence of fields. You want to make a diagram per “Price” field.  

By selecting  “Priority”  field  in  “Data  Levels”  box  you  will  diagram “price-priority”  relation  (the  value  of 
“Price” field for each value of “Priority” field).  

Left  click  on  “Select  value”  drop-down  list  to  select  one  of  the  values  of  “Priority”  field  that  the  tasks  of 
selected task group have or click on the corresponding diagram for this value. For example, you select “Low” 
priority and in  that  way you diagram the values  of  “price” field  for  each  value  of  “Complete” field  of  the 
tasks with “Low” priority.  

  

OR 
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By selecting definite value of “Complete” field from corresponding drop-down list or clicking on the diagram 
for this value, e.g. 10.00 %, you will diagram the price value of the tasks that have selected “Complete” value 
(10.00 %). 

OR 
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You  can  return  to  required  data  level  by  selecting  corresponding  field  on  “Data  Levels”  box  or  right 
clicking on the diagram in series. 

9. Print out required diagram or preview it and create your own print design by clicking on “Print…” or 
“Preview…” button on Charts toolbar correspondingly. 
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4.1.32.How to send the tasks by e-mail 

To send the tasks by e-mail use following steps: 
1. Go to Start -> All Programs -> VIP Quality Software -> VIP Task Manager Professional -> Database 

Manager 

2. Select ‘SMTP’ tab in Database Manager’ window 

3. Check ‘Enable E-Mail sending’ option 
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4. Enter host name of your SMTP server into ‘Host:’ entry field 

5. Enter SMTP port into ‘Port:’ entry field 

6. Select the type of authentication from ‘Authentication’:  drop-down list 
None – if there is no need in login and password while accessing SMTP 
Login – if only login and password are required to access SMTP 
Login(TLS) – if SSL-connection is used to access SMTP 
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7. Enter user name for authorization into ‘User:’ entry field 

8. Enter user password for authorization into ‘Password:’ entry field 
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9. Change time-out value in ‘Check every’ entry field, if needed, and click ‘Apply’ button 

10. Enter your name into ‘Sender Name:’ entry field. It will be added to the message 
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11. Enter your e-mail address into ‘Sender E-Mail:’ entry field. It will be added to the message to ‘From’ 
field. 

12. Click ‘Apply’ button  
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13. Click ‘Test’ button to send test message 

14. Click ‘Close’ button 
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15. Start  VIP Task  Manager,  right  click  on  required task  and  select  ‘Sending task(s)  by Email…’ from 
drop-down list 

Note:  
· To select several tasks simultaneously,  click them while holding ‘Ctrl’ or ‘Shift’ (if  the tasks are 

one by one) key 

16. Check data section you want to be sent with the task 
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General – task name, priority,  task group 
this  task  belongs  to,  Estimated  &  Actual 
Time,  Workflow,  Status,  Complete,  Due 
Date, Start & Finish Date 
Assignments  –  the  names  of  resources 
selected task is assigned to 
Attachments  –  the  types,  names  and 
descriptions  of  attachments  of  selected 
task 
Notes – notes of selected task  
Comments  – comments of selected task  
History – a history of task changes 
Custom  fields  –  names  and  values  of 
custom fields selected task has 

Tips:  

· To quickly select all data sections click on  button 

· To quickly uncheck all data sections click on  button 

17. Check ‘Also send attachments’ option to send the files or links attached to selected task together with 
the task 

18. Click ‘Next’ button 
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19. Check ‘Assigned resources’ radio button to send selected task to the resources assigned to this task. 
The list contains only resources who have e-mail address in ‘E-mail’ field 

20. Alternatively, select ‘Custom list’ radio button and check resources for sending e-mail  
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Tips:  

· To quickly select all resources click on  button 

· To quickly clear resource list click on  button 

21. Enter additional e-mail addresses selected task will be sent to into corresponding entry field. Several 
e-mail addresses are separated by comma or semicolon 

22. Click ‘Next’ button 
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23. Select required template from ‘Templates’ drop-down list. This template defines the view of outgoing 
message. 

Note:  

 You can create your own templates, go to the folder with VIP Task Manager product (by default it’s 
path is C:\Program Files\VIP Quality Software\VIP Task Manager Professional) and put them into ‘ 
XSLT’ folder. After that your templates will be available in ‘Templates’ drop-down list of ‘Setting 
parameters for sending tasks via E-Mail’ window. 
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24. Enter the header of e-mail into ‘Message header’ entry field 

25. Enter the footer of e-mail into ‘Message footer’ entry field 

26. Click ‘Send’ button 
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27. Click ‘Ok’ button in appeared information message. Your e-mail will be sent when timeout is finished 
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4.1.33.How to send notifications of task changes by e-mail 

To send notifications of task changes by e-mail use following steps: 
1. Enter SMTP settings 
2. Open ‘New Resource’ or ‘Edit Resource’ dialog 
3. Select ‘Notification’ tab 

4. Check ‘Sending notifications by Email’ option and click ‘Ok’ button 
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4.1.34.How to import from MS Outlook 

To import the tasks from MS Outlook use the following steps: 
1. Start MS Outlook 
2. Start Task Manager 
3. Go to main menu command [File -> Import from Outlook…] 

4. Open ‘Import into:’ drop-down box and select task group to import the tasks from MS Outlook 
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Note:  
· To select task group you can highlight it and click ‘Ok’ button or double click on task group 
· To  create  new  task  group,  edit,  delete,  sort,  expand  or  collapse  existing  ones  click  on 

corresponding button on ‘Import into:’ drop-down box toolbar 

5. Check ‘Import uncompleted tasks only’ option to import only the undone tasks  

6. Check  ‘Divide  tasks  into  groups  (Tasks,Jornals  etc.)’  option  to  import  the  tasks,  journals, 
appointments,  etc into corresponding task groups in  the same form as  they are in  Outlook.  Task 
Manager automatically creates ‘Tasks’, ‘Journals’, ‘Appointments’, etc, task groups. If this option 
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is not checked, tasks, journals, etc will be placed into selected task group. 

7. Check ‘Don’t import attachments’ option to import the data from Outlook without attachments 

8. Check  “Don’t  import  tasks  that  were  imported  before”  and  “Don’t  import  contacts  that  were 
imported before” options not to rewrite the tasks and contacts that imported earlier. 
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9. Check the data groups  from ‘Outlook groups:’  section to  import  from Outlook  (tasks,  journals, 
appointments, contacts) and click ‘Ok’ button 

10. MS Outlook asks your permission to access its e-mail database. Check ‘Allow access for’ option, 
select time interval from drop-down list and click ‘Ok’ button 
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4.1.35.How to assign a task to its owner by default 

You can set the program to automatically assign newly created task to its owner. This will work only for task groups 
that don't have default resource (how to assign a default resource to tasks within certain task groups). To assign a 
task to its owner by default use the following steps: 

1. Go to main menu command [Tools -> Options] 

2. Check ‘Assign task to owner by default’ option and click ‘Ok’ button 
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4.1.36.How to make HTML or RTF reports of the tasks 

To make HTML or RTF reports of the tasks do the steps below: 
1. Right click on required task on Task List, Task Tree or Calendar view and select ‘Print task(s)…’ 

from drop-down list 

2. Check required data sections that will be included into the report 

General  –  task  name,  priority,  task  group 
this  task  belongs  to,  Estimated  &  Actual 
Time,  Workflow,  Status,  Complete,  Due 
Date, Start & Finish Date 
Assignments  –  the  names  of  resources 
selected task is assigned to 
Attachments  –  the  types,  names  and 
descriptions of attachments of selected task 
Notes – notes of selected task  
Comments – comments of selected task  
History – a history of task changes 
Custom  fields  –  names  and  values  of 
custom fields selected task has 

Tips:  

· To quickly select all data sections click on  button 
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· To quickly uncheck all data sections click on  button 

3. Select ‘RTF’ radio button to make RTF report or ‘HTML’ radio button to make HTML reports of the 
task. 

4. For HTML reports select  required template from ‘Templates’  drop-down list.  This  template defines 
the view of the report. 
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Note:  

 You can create your own templates, go to the folder with VIP Task Manager product (by default it’s 
path is C:\Program Files\VIP Quality Software\VIP Task Manager Professional) and put them into ‘ 
XSLT’ folder. After that your templates will be available in ‘Templates’ drop-down list of ‘Report 
options’ window. 

5. Click ‘Build report’ button 
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4.2. Task Groups 

4.2.1. How to create new task group 

There are several ways to create new task group. 
1. Click on “New Group” button on Task Group Panel toolbar, or Task Tree toolbar.  

OR 

2. Press “Ctrl + G” key 
3. Right click on  Task Tree grid and select “New Group” from drop-down list 

4. Right click on  Task Groups Panel tree and select “New” from drop-down list 

In  “New  Folder”  dialog  on  “General”  tab  enter  task  group  name  into  “Name”  entry  field.  Open  “Task 
Group” drop-down box, select required parent task group from task group tree and click “Ok”. 
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4.2.2. How to edit task group 

There are several ways to edit task group. 
1. Select required task group and click on “Edit Group” button on Task Groups Panel toolbar  

2. Select required task group and click on “Edit Group” button on Task Tree toolbar 

3. Select required tasks group and press “F4” key 
4. Right click on task group on Task Tree grid and select “Edit” from drop-down list 

5. Double click on task group on Task Tree grid 
6. Right click on task group on Task Groups panel and select “Edit” from drop-down list 
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4.2.3. How to delete task group 

There are several ways to delete task group: 
1. Select required task group and click on “Delete Group” button on Task Group panel toolbar  

2. Select required task group and press “Delete” key 
3. Select required task group and click on “Delete” button on Task Tree toolbar 

4. Select required task group on Task Tree grid and press “F8” key 
5. Right click on selected task group on Task Tree grid and select “Delete” from drop-down list 

6. Right click on task group on Task Groups panel and select “Delete” from drop-down list 
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In confirmation window click “Ok” if you want to delete this task group, or “No” if not. 
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4.2.4. How to add notes to task group 

To add notes to task group use following steps: 
1. Open “New Folder” or “Edit Folder” dialog 
2. Select “Note” tab 
3. Enter required notes into note entry field 
4. Create your own note design using Note toolbar 
5. Click “Ok” 

Tips: 

 To insert current date & time into the notes position the cursor in the required place of Notes panel 
and press ‘F5’ key 

 To display task group notes as plain text under the task group in Task Tree grid click on “Preview 
Mode” button on Task Tree toolbar and select “Note as plain” from drop-down list 

 To display task group notes as RTF under the task group in Task Tree grid click on “Preview 
Mode” button on Task Tree toolbar and select “Note as RTF” from drop-down list 

 To hide task group notes from Task Tree grid click on “Preview Mode” button on Task Tree toolbar 
and select “None’ from drop-down list 
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4.2.5. How to sort task groups 

Task groups can be sorted manually using following steps: 

1. Right  click on Task  Tree  grid  and select  “Manual  Sorting”  from drop-down list  or  click  on    
button on Task Tree toolbar or press “Ctrl + 0” key 

2. Select task group you want to replace 
3. Right click on Task Tree grid and select “Move Up”/”Move Down” from drop-down list or click on 

  /  buttons on Task Tree toolbar or press “Ctrl + Up” / “Ctrl + Down” keys 

Alternatively, select required task group on Task Groups panel and click on “Move Down” / “Move Up” 
buttons. 
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4.2.6. How to assign the resource to receive notifications of task group changes 

To select the supervisors for task group use following steps: 
1. Open “New Folder” or “Edit Folder” dialog 
2. Select “Watch List” tab 
3. Select required resources 
4. Click “Ok” 

Tips: 

· To quickly select all resources in the list click, on  (“Check All”) button 

· To quickly clear the list of supervisors, click on   (“Uncheck All”) button 
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4.2.7. How to set custom fields for the task group 

To set custom fields for the task group use following steps: 
1. Right click on required task group on Task Groups panel or on Task Tree grid 
2. Select “Custom fields options” from drop-down list 

3. Select required custom field from the list 

4. Select “Subgroups&tasks” from “Setting for” drop-down list to relate highlighted custom field to all 
tasks and task groups of current task group. If you select “This task group”, highlighted custom field 
will be related to current task group and won’t be related to its subgroups and tasks.  
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5. Select  “Enable”  from  drop-down  list  to  activate  highlighted  custom  field,  “Disable”  –  to  make  it 
invisible for current task group or make it the same as for parent task group by selecting “Disable by 
parent”/”Enabled by parent”. If the custom field is enabled, it has green circle, otherwise this circle is 
grey. 

6. Check “View in preview sections” option to display current custom field in custom field info,  in task 
screen tips on Calendar grid and Print Preview Window  
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7. If this custom field may be entered by user, check “Edit” option. For task group it may be calculated per 
other  tasks’  custom  fields  that  are  enabled  for  this  particular  task  group.  For  the  latter  case  check 
“Aggregated (for task group)” option and select one of the arithmetic operations and required custom 
field from corresponding drop-down lists. 

Arithmetic operations that are available for calculation per tasks’ custom fields: 
Count – the quantity of the tasks that have definite custom field 
Sum – the sum value of this custom field per all tasks in current task group 
Avg – the average value of this custom field per all tasks in current task group 
Min – minimum value of this custom field per all tasks in current task group 
Max – maximum value of this custom field per all tasks in current task group 

OR 
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8. If you enter some formula for current custom field while creating it, you can activate it for this task 
group by checking “Calculated by custom field formula (for task group)”.  In this case options “Edit” 
and “Aggregated (for task group)” become disabled.  

9. Click “Ok”. 
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4.2.8. How to enter custom field values of the task group 

To enter custom field values of the task group use following steps: 
1. Open “New Folder” or “Edit Folder” dialog 
2. Select Custom Fields tab 
3. Enter required values by using the keyboard or up-down buttons or select custom field values from 

predefined drop-down list according to the type of the custom field 
4. Click ‘Ok’  
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4.2.9. How to place the task group to archive and return it back 

In archive mode you can’t make any changes with the tasks and task groups. 
To place task group to archive use following steps: 

1. Right click on required task group on Task Groups panel or on Task Tree grid 
2. Select “Move to archive” from drop-down list  

OR 

After that selected task group will disappear from your task tree.  
To return it from archive use following steps: 

1. Select main menu command [File -> Archive mode] 

2. Right click on required task group on Task Groups panel or on Task Tree grid 
3. Select “Restore from archive” from drop-down list 

OR  
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4.2.10.How to duplicate the task group 

To duplicate the task group follow the steps below: 
1. On Task List  or Calendar view right click on required task group on Task Groups panel and select 

“Duplicate task group…” from drop-down list. On Task Tree view right click on required task group 
on Task Tree grid and select “Duplicate” from drop-down list or press “Ctrl + D” keys.  

OR 

2. Open “Task group” drop-down box, select task group where you want to insert duplicated task group 
and click “Ok”. 

3. Check “Start date” option, select “Start date” or “Finish date” from drop-down list and select required 
date  from  corresponding  drop-down  box.  For  example,  you  select  “Start  date”  and  some  task  of 
duplicated task group has 01/10/2007 Start Date, 03/10/2007 Finish Date and 04/10/2007 Due Date. 
When you select new start date, e.g. 03/10/2007, task finish and due dates will be postponed for the 
difference between new and old start  dates.  In  our  example new finish date is  05/10/2007 and new 
due date is 06/10/2007. The same situation is with all tasks of duplicated task group.  
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4. Check ‘Copy permissions’ option to save permissions assigned to task group while duplicating it and 
click ‘Ok’ button 

Note: 

 If ‘Copy permissions’ option is unchecked, duplicated task group will inherit the permissions from 
task group it is inserted into 

 ‘View’  permission  of  duplicated  task  group  is  inherited  from  task  group  it  is  inserted  into.  For 
example,  particular  resource  or  role  is  allowed  to  view  task  group  'Stage  2'.  If  it  is  duplicated  to 
'Project  1'  task  group  with  denied  'View'  permission  for  this  resource  or  role,  then  'Stage  2'  task 
group will be invisible for this resource or role. 
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4.2.11.How to insert the duplicate of task group 

To insert the duplicate of task group follow the steps below: 
1. Go to Task List or Calendar view, right click on required task group on Task Groups panel or select 

Task Tree view and right click on required task group on Task Tree grid 
2. Select “Insert copy of task group…” from drop-down list 

OR 

3. Open “Task group” drop-down box, select task group that you want to copy and click “Ok”. 

4. Check “Start date” option, select “Start date” or “Finish date” from drop-down list and select required 
date  from  corresponding  drop-down  box.  For  example,  you  select  “Start  date”  and  some  task  of 
duplicated task group has 01/10/2007 Start Date, 03/10/2007 Finish Date and 04/10/2007 Due Date. 
When you select new start date, e.g. 03/10/2007, task finish and due dates will be postponed for the 
difference  between new and old start  dates.  In  our  example new finish  date is  05/10/2007 and new 
due date is 06/10/2007. The same situation is with all tasks of duplicated task group.  
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5. Check ‘Copy permissions’ option to save permissions assigned to task group while duplicating it and 
click ‘Ok’ button  

Note: 

 If ‘Copy permissions’  option is  unchecked,  duplicated task group will  inherit  the permissions from 
task group it is inserted into. 

 ‘View’  permission  of  duplicated  task  group  is  inherited  from  task  group  it  is  inserted  into.  For 
example,  particular  resource  or  role  is  allowed  to  view  task  group  'Stage  2'.  If  it  is  duplicated  to 
'Project 1' task group with denied 'View' permission for this resource or role, then 'Stage 2' task group 
will be invisible for this resource or role. 
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4.2.12.How to assign default resource(s) for the task group 

If  you  want  all  tasks  of  particular  task  group  to  be  assigned  to  particular  resource(s)  by  default,  use 
following steps: 

1. Open “New Folder” or “Edit Folder” dialog 
2. Select tab “Resources” 
3. Check “Default assignments” option 
4. Select required resources from the list 
5. Click “Ok” 
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4.2.13.How to make graphic reports on the task group 

To make graphic report on task group use following steps: 
1. Go to Task Tree view and select required task group on Task Tree grid or set filter by required task 

group on Task List or Calendar views. 

OR  

     

2. Go to “Charts” panel 
3. Select required fields for the diagrams from the corresponding drop-down lists on Charts toolbar 

4. If  the  tasks  are  grouped  by  any  field  you  can  display  the  sum,  minimum,  maximum,  quantity  and 
average value for task field on the diagrams. Select required operation from corresponding drop-down 
list on Charts toolbar. 

5. Select required type of diagram from the drop-down list in the right upper part of Chart panel 
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6. Click on “Customize Chart” button, check those diagrams that you want to display and uncheck the 
rest  ones.  From “Sort  by” drop-down list  select  the field  you want  the diagram to be sorted by and 
click on the button nearby to select the type of sorting – ascending or descending. 

Select  “Data Groups” tab,  drag data level  that  you want  to  hide and drop it  to  the empty space on “Data 
Groups” tab. To display data level that was hidden earlier, drag it on “Data Groups” tab and drop it where 
you need on “Data Levels” box. 

Select “Options” tab and set required appearance for diagram legend, title and customization zone. If  you 
want  value  hints  to  be  shown  while  directing  the  cursor  to  the  diagram,  check  corresponding  option  on 
“Options” tab, or uncheck it otherwise.  
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7. “Data  Levels”  option  demonstrates  the  order  of  the  diagramed  fields.  To  change  their  order  drag 
required field’s title and drop it where you need on “Data Levels” box. 

For example, the tasks in your list are grouped by “Priority” and “Complete” fields. In “Data Levels” box 
you will see the same sequence of fields. You want to make a diagram per “Price” field.  
By selecting “Priority” field in “Data Levels” box you will diagram “price-priority” relation (the value of 
“Price” field for each value of “Priority” field).  

Left click on “Select value” drop-down list to select one of the values of “Priority” field that  the tasks of 
selected  task  group  have  or  click  on  the  corresponding  diagram  for  this  value.  For  example,  you  select 
“Low” priority and in that way you diagram the values of “price” field for each value of “Complete” field of 
the tasks with “Low” priority.  
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OR 

  

By  selecting  definite  value  of  “Complete”  field  from  corresponding  drop-down  list  or  clicking  on  the 
diagram  for  this  value,  e.g.  10.00  %,  you  will  diagram  the  price  value  of  the  tasks  that  have  selected 
“Complete” value (10.00 %). 

OR 
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You  can  return  to  required  data  level  by  selecting  corresponding  field  on  “Data  Levels”  box  or  right 
clicking on the diagram in series. 

8. Print out required diagram or preview it and create your own print design by clicking on “Print…” or 
“Preview…” button on Charts toolbar correspondingly. 
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4.2.14.How to send task groups by e-mail 

To send task groups by e-mail use following steps: 
1. Enter SMTP settings 
2. Start  VIP  Task  Manager,  right  click  on  required  task  group  and  select  ‘Sending  task(s)  by  Email…’ 

from drop-down list 

Note:  
· To  select  several  task  groups 

simultaneously,  click  them  while 
holding  ‘Ctrl’  or  ‘Shift’  (if  task 
groups are one by one) key 

3. Check data sections you want to be sent with task group 

General  –  task  group  name,  task  group 
this  task group belongs  to,  total  Estimated 
& Actual Time of the tasks of selected task 
group,  average  completion  percent  of  the 
tasks of selected task group 
Assignments  –  the  names  of  resources 
selected task group is assigned to 
Notes – notes of selected task group  
History – a history of task group changes 
Custom  fields  –  names  and  values  of 
custom fields selected task group has 

Note: 
· Attachments  and Comments  data sections  make sense only for  the tasks.You can  check them 

for task groups, but they won’t be included in the e-mail. 
Tips:  

· To quickly select all data sections click on  button 
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· To quickly uncheck all data sections click on  button 

4. Click ‘Next’ button 

5. Select ‘Custom list’ radio button and check resources for sending e-mail 

Note:  

 ‘Assigned resources’ radio button makes sense only for the tasks. If you select it for task groups, the 
error message will appear. 

Tips:  

· To quickly select all resources click on  button 
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· To quickly clear resource list click on  button 

6. Enter  additional  e-mail  addresses  selected  task  group  will  be  sent  to  into  corresponding  entry  field. 
Several e-mail addresses are separated by comma or semicolon 

7. Click ‘Next’ button 

8. Select required template from ‘Templates’ drop-down list.  This template defines the view of outgoing 
message. 
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Note: 

 You can create your own templates, go to the folder with VIP Task Manager product (by default it’s 
path is C:\Program Files\VIP Quality Software\VIP Task Manager Professional) and put them into ‘ 
XSLT’ folder. After that your templates will be available in ‘Templates’ drop-down list of ‘Setting 
parameters for sending tasks via E-Mail’ window. 

9. Enter the header of e-mail into ‘Message header’ entry field 

10. Enter the footer of e-mail into ‘Message footer’ entry field 
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11. Click ‘Send’ button 

12. Click ‘Ok’ button in appeared information message. Your e-mail will be sent when timeout is finished  
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4.3. Resources 

4.3.1. How to create a new resource 

There are several ways to create a new resource. 
1. Click on “New Resource” button on Resource List toolbar. 

2. Press “Ins” key 
3. Right click on Resource List grid and select “New Resource” from drop-down list 

4. Double click on Resource List grid 

In  “New  Resource”  dialog  on  “General”  tab  enter 
resource name, e-mail, department, job title, address 
and  phone  into  corresponding  entry  fields.  Into 
“Password” entry field enter the password that you 
will  be  asked  during  program  setup.  Assign 
“Login”,  “Assignment”  and  “Administration” 
permissions  to resource if required and click “Ok”. 



 

User Manual VIP Task Manager Pro 269 

 

4.3.2. How to edit a resource 

There are several ways to edit a resource. 
1. Select required resource and click on “Edit Resource” button on Resource List toolbar.  

2. Select required resource and press “F4” key 
3. Right click on required resource on Resource List grid and select “Edit Resource” from drop-down list 

4. Double click on required resource on Resource List grid 

Tip: 

 To edit current resource setting select main menu command [File -> Edit User Profile]. 
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4.3.3. How to delete a resource 

There are several ways to delete a resource: 
1. Select required resource and click on “Delete Resource” button on Resource List toolbar. 

2. Select required resource and press “F8” key 
3. Select required resource and press “Delete” key 
4. Right click on required resource on Resource List grid and select “Delete Resource” from drop-down 

list 

In confirmation window click “Ok” if you want to delete this task, or “No” if not. 
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4.3.4. How to create a new role 

There are several ways to create a new role. 
1. Click on “New Role” button on Roles Panel toolbar.  

2. Right click on Roles Panel grid and select “New Role” from drop-down list 

3. Double click on Roles Panel grid 
4. In “New Resource” or “Edit Resource” dialog select Roles tab and click on “New Role” button or 

press “Ins” key 
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4.3.5. How to edit a role 

There are several ways to edit a role. 
1. Select required role and click on “Edit Role” button on Roles Panel toolbar.  

2. Right click on required role on Roles Panel grid and select “Edit Role” from drop-down list 

3. Double click on required role on Roles Panel grid 
4. In “New Resource” or “Edit Resource” dialog select Roles tab, select required role and click on “Edit 

Role” button or press “F4” key 
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4.3.6. How to delete a role 

There are several ways to delete a role: 
1. Select required role and click on “Delete Role” button on Roles Panel toolbar. 

2. Right click on required role on Roles Panel grid and select “Delete Role” from drop-down list 

3. In  “New  Resource”  or  “Edit  Resource”  dialog  select  Roles  tab,  select  required  role  and  click  on 
“Delete Role” button or press “Del” key 

In confirmation window click “Ok” if you want to 
delete this task, or “No” if not. 
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4.3.7. How to assign resource(s) to role 

Resources may be assigned to particular role by using following steps: 
1. Open “New Resource” or “Edit Resource” dialog 
2. Select “Roles” tab 
3. Select the role you want this resource to assign to 
4. Click “Ok” 

Tips: 

 To quickly select all roles, click on  (“Check All”) button 

 To quickly clear the list of roles, click on   (“Uncheck All”) button 
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4.3.8. How to assign permissions to role and resource 

Use following steps to allow or deny roles or resources to manage task groups: 
1. Select Task Tree view 
2. Select required task group 
3. Go to Permissions panel 
4. Change the permission to view, create, edit, delete or set permissions opposite required resource or role 

by using Permissions toolbar or right clicking on this cell 
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4.3.9. How to filter resource 

To  filter  resources  on  Resource  List  grid  by  particular  column  click  on  this  column  header  to  open 
drop-down list, select required department or job title to display only resources assigned to this department 
or with this job title. 

If you want to display all resources without filtering, select “(All)” from drop-down list. 
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4.3.10.How to set task notifications 

To set task changes notifications use following steps: 
1. Open “New Resource” or “Edit Resource” dialog 
2. Select “Notifications” tab 
3. Select required fields to be informed about 
4. Click “Ok” 

Tips: 

 To quickly select all task fields, click on  (“Check All”) button 

 To quickly clear the list of fields, click on   (“Uncheck All”) button 
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4.3.11.How to assign supervised resource 

To assign supervised resources use following steps: 
1. Open “New Resource” or “Edit Resource” dialog 
2. Select “Watch List” tab 
3. Select required resources from List of supervised resources 
4. Click “Ok” 

Tips: 

· To quickly select all resources, click on  (“Check All”) button 

· To quickly clear the list of resources, click on   (“Uncheck All”) button 
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4.3.12.How to sort resources 

Resources can be sorted within any column by several ways: 
1. Left  click on column header.  To change the  direction  of  sorting,  left  click  on  this  column header 

again. 
2. Right click on column header and select  “Sort  Ascending” or  ”Sort  Descending” from drop-down 

list 

OR 

To clear resources sorting right click on column header and select “Clear Sorting” from drop-down list. 
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4.3.13.How to group resources 

Resources can be grouped by any column by several ways: 
1. If there is no grey space above Resource List grid right click on column header and select “Group 

By  Box”  from  drop-down  list.  Then  drag  this  column  header  and  drop  it  on  the  space  above 
Resource List grid. 

                                                                    

                                                                               

2. Right click on column header and select “Group By This Field” from drop-down list 

If you want to group resources by several fields simultaneously, group by each field step by step using one 
of the ways mentioned above. 
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4.3.14.How to export Resource List 

There are several ways to export Resource List view to MS Excel or HTML. 
1. Select main menu commands [File -> Export View To Excel…] or [File -> Export View To HTML…] , 

enter export file name and path in “Export File Name” dialog. 

2. Right click on Resource List grid and select “Export View To Excel…” or “Export View To HTML…” 
from drop-down list, enter export file name and path in “Export File Name” dialog. 
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4.3.15.How to print out Resource List 

There are several ways to print out Resource List view. 
1. Select main menu command [File -> Print…], enter print settings in “Print” dialog and click on 

“Print” button. 

  

2. Right  click  on  Resource  List  grid  and  select  “Print…”  from  drop-down  list,  enter  print  settings  in 
“Print” dialog and click on “Print” button. 

3. Press “Ctrl + P” keys. 

You can preview Resource List view, create your own print design using several 
 ways: 

1. Select main menu command [File -> Print…], click on “Preview…” button in “Print” dialog. 
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2. Select main menu command [File -> Print Preview…]. 

3. Press “Shift + Ctrl + P” keys. 
4. Right click on Resource List grid and select “Print Preview…” from drop-down list. 
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How to create print design see How to work with Print Preview Window 


